---
id: CVE-2026-124463
title: OpenEMR before 8.3.0 Stored XSS via CAMOS Rx Print View
summary: >-
  OpenEMR before 8.3.0 contains a stored cross-site scripting vulnerability that
  allows authenticated users with CAMOS access to inject HTML by saving
  malicious CAMOS content through ajax_save.php. Attackers can store a script
  payload that…
severity: high
cvss: 8.7
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: openemr
product: openemr
affected:
  - openemr < 8.3.0
published: '2026-11-08'
updated: '2026-11-08'
sourceUpdated: '2026-11-08T13:15:49.914Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-124463'
references:
  - url: 'https://github.com/openemr/openemr/security/advisories/GHSA-rc6m-6pq4-r69x'
    label: GitHub Security Advisory (GHSA-rc6m-6pq4-r69x)
  - url: >-
      https://www.vulncheck.com/advisories/openemr-before-8.3.0-stored-xss-via-camos-rx-print-view
    label: >-
      VulnCheck Advisory: OpenEMR before 8.3.0 Stored XSS via CAMOS Rx Print
      View
tags:
  - cve.org
ingestedAt: '2026-11-08T13:50:34.971Z'
---

## Overview

OpenEMR before 8.3.0 contains a stored cross-site scripting vulnerability that allows authenticated users with CAMOS access to inject HTML by saving malicious CAMOS content through ajax_save.php. Attackers can store a script payload that executes unencoded when the entry is printed via the non-print_html branch of rx_print.php, performing actions and reading data as the victim user.

## Affected

- `openemr < 8.3.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
