---
id: CVE-2026-12626
title: >-
  The Online Scheduling and Appointment Booking System – Bookly plugin for
  WordPress is vulnerable to PHP Object Injection in all versions up to, and
  including, 28.2 via deserialization of untrusted input via the ‘value’
  parameter
summary: >-
  The Online Scheduling and Appointment Booking System – Bookly plugin for
  WordPress is vulnerable to PHP Object Injection in all versions up to, and
  including, 28.2 via deserialization of untrusted input via the ‘value’
  parameter. This ma…
severity: high
cvss: 7.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-502
published: '2026-10-10'
updated: '2026-10-13'
sourceUpdated: '2026-10-13T13:30:21.620'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-12626'
references:
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3707284/bookly-responsive-appointment-booking-tool
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/56c5e045-e91c-4517-8164-a21c3e99623b?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00309
epssPercentile: 0.23823
ingestedAt: '2026-10-10T07:26:21.923Z'
vendor: ladela
product: Online Scheduling and Appointment Booking System – Bookly
affected:
  - online_scheduling_and_appointment_booking_system_bookly <= 28.2
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-11T16:40:42.812321Z'
---

## Overview

The Online Scheduling and Appointment Booking System – Bookly plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 28.2 via deserialization of untrusted input via the ‘value’ parameter. This makes it possible for authenticated attackers, with custom-level access and above, to inject a PHP Object. No known gadget chain is available.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
