---
id: CVE-2026-12770
aliases:
  - GHSA-6qr3-3g89-m4jj
  - PYSEC-2026-4068
title: 'LiteLLM: Admin Key Handler Has Improper Authorization'
summary: 'LiteLLM: Admin Key Handler Has Improper Authorization'
severity: medium
cvss: 5.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L'
vendor: litellm
product: litellm
ecosystem: pip
affected:
  - litellm <= 1.63.1
published: '2026-06-21'
updated: '2026-10-01'
sourceUpdated: '2026-10-01T17:55:46.994048972Z'
source: OSV
sourceUrl: 'https://osv.dev/vulnerability/GHSA-6qr3-3g89-m4jj'
references:
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-12770'
  - url: 'https://github.com/BerriAI/litellm/pull/23781'
  - url: 'https://gist.github.com/YLChen-007/993c68152b2c770d53590f1684c755d4'
  - url: 'https://github.com/BerriAI/litellm'
  - url: 'https://vuldb.com/cve/CVE-2026-12770'
  - url: 'https://vuldb.com/submit/811279'
  - url: 'https://vuldb.com/vuln/372512'
  - url: 'https://vuldb.com/vuln/372512/cti'
  - url: 'https://pypi.org/project/litellm'
  - url: 'https://github.com/advisories/GHSA-6qr3-3g89-m4jj'
tags:
  - osv
  - pip
  - ghsa
epss: 0.00569
epssPercentile: 0.46936
cwe:
  - CWE-266
ingestedAt: '2026-09-10T23:08:11.245Z'
---

## Overview

A vulnerability was determined in BerriAI litellm up to 1.63.1. The impacted element is an unknown function of the file litellm/proxy/management_endpoints/key_management_endpoints.py of the component Admin Key Handler. This manipulation causes improper authorization. The attack can be initiated remotely. The exploit has been publicly disclosed and may be utilized. The vendor was contacted early about this disclosure.

## Affected packages

- `litellm <= 1.63.1`

## Remediation

Refer to the advisory for the patched release.
