---
id: CVE-2026-12882
title: >-
  Mattermost versions 11.9.x <= 11.9.0, 11.8.x <= 11.8.4, 11.7.x <= 11.7.7,
  10.11.x <= 10.11.22 fail to parse Markdown autolinks with unmatched trailing
  closing parentheses in linear time, which allows an authenticated user with
  permission…
summary: >-
  Mattermost versions 11.9.x <= 11.9.0, 11.8.x <= 11.8.4, 11.7.x <= 11.7.7,
  10.11.x <= 10.11.22 fail to parse Markdown autolinks with unmatched trailing
  closing parentheses in linear time, which allows an authenticated user with
  permission…
severity: medium
cvss: 4.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L'
cwe:
  - CWE-407
vendor: mattermost
product: mattermost_server
affected:
  - 'mattermost_server >= 10.11.0, < 10.11.23'
  - 'mattermost_server >= 11.7.0, < 11.7.8'
  - 'mattermost_server >= 11.8.0, < 11.8.5'
  - 'mattermost_server >= 11.9.0, < 11.9.1'
patched:
  - mattermost_server 11.9.1
published: '2026-09-14'
updated: '2026-10-07'
sourceUpdated: '2026-10-07T16:23:29.577'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-12882'
references:
  - url: 'https://mattermost.com/security-updates'
    label: responsibledisclosure@mattermost.com
tags:
  - nvd
  - cve.org
epss: 0.00367
epssPercentile: 0.304
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-09-14T11:02:14.110168Z'
ingestedAt: '2026-09-14T15:23:07.462Z'
---

## Overview

Mattermost versions 11.9.x <= 11.9.0, 11.8.x <= 11.8.4, 11.7.x <= 11.7.7, 10.11.x <= 10.11.22 fail to parse Markdown autolinks with unmatched trailing closing parentheses in linear time, which allows an authenticated user with permission to create posts to cause excessive server CPU consumption and degrade availability for other users via specially crafted post or message attachment content. Mattermost Advisory ID: MMSA-2026-00703

## Affected

- `mattermost_server >= 10.11.0, < 10.11.23`
- `mattermost_server >= 11.7.0, < 11.7.8`
- `mattermost_server >= 11.8.0, < 11.8.5`
- `mattermost_server >= 11.9.0, < 11.9.1`

## Remediation

Upgrade past the affected range:

- `mattermost_server 11.9.1`
