---
id: CVE-2026-13258
title: >-
  IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6,
  10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 is vulnerable to
  cross-site scripting
summary: >-
  IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6,
  10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 is vulnerable to
  cross-site scripting. This vulnerability allows an authenticated user to embed
  arbitrary …
severity: medium
cvss: 5.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N'
cwe:
  - CWE-79
vendor: ibm
product: datapower_gateway
affected:
  - 'datapower_gateway >= 10.5.0.0, < 10.5.0.23'
  - 'datapower_gateway >= 10.6.0.0, < 10.6.0.11'
  - 'datapower_gateway >= 10.6.1.0, < 11.0.0.3'
  - 'datapower_gateway >= 11.0.0.0, < 11.0.0.3'
patched:
  - datapower_gateway 11.0.0.3
published: '2026-10-08'
updated: '2026-10-14'
sourceUpdated: '2026-10-14T23:59:08.033'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-13258'
references:
  - url: 'https://www.ibm.com/support/pages/node/7289775'
    label: psirt@us.ibm.com
tags:
  - nvd
  - cve.org
epss: 0.00165
epssPercentile: 0.05717
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-08T17:28:53.798292Z'
ingestedAt: '2026-10-08T14:47:16.366Z'
---

## Overview

IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6, 10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 is vulnerable to cross-site scripting. This vulnerability allows an authenticated user to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session.

## Affected

- `datapower_gateway >= 10.5.0.0, < 10.5.0.23`
- `datapower_gateway >= 10.6.0.0, < 10.6.0.11`
- `datapower_gateway >= 10.6.1.0, < 11.0.0.3`
- `datapower_gateway >= 11.0.0.0, < 11.0.0.3`

## Remediation

Upgrade past the affected range:

- `datapower_gateway 11.0.0.3`
