---
id: CVE-2026-13417
title: >-
  Mattermost versions 11.9.x <= 11.9.0, 11.8.x <= 11.8.4, 11.7.x <= 11.7.7,
  10.11.x <= 10.11.22 fail to validate the type of `fields.properties` on block
  creation which allows an authenticated user with editor access to a board to
  crash th…
summary: >-
  Mattermost versions 11.9.x <= 11.9.0, 11.8.x <= 11.8.4, 11.7.x <= 11.7.7,
  10.11.x <= 10.11.22 fail to validate the type of `fields.properties` on block
  creation which allows an authenticated user with editor access to a board to
  crash th…
severity: medium
cvss: 4.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L'
cwe:
  - CWE-754
vendor: mattermost
product: mattermost_server
affected:
  - 'mattermost_server >= 10.11.0, < 10.11.23'
  - 'mattermost_server >= 11.7.0, < 11.7.8'
  - 'mattermost_server >= 11.8.0, < 11.8.5'
  - 'mattermost_server >= 11.9.0, < 11.9.1'
patched:
  - mattermost_server 11.9.1
published: '2026-09-14'
updated: '2026-10-07'
sourceUpdated: '2026-10-07T16:17:21.987'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-13417'
references:
  - url: 'https://mattermost.com/security-updates'
    label: responsibledisclosure@mattermost.com
tags:
  - nvd
  - cve.org
epss: 0.00367
epssPercentile: 0.30399
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-09-14T11:03:53.719633Z'
ingestedAt: '2026-09-14T15:23:07.462Z'
---

## Overview

Mattermost versions 11.9.x <= 11.9.0, 11.8.x <= 11.8.4, 11.7.x <= 11.7.7, 10.11.x <= 10.11.22 fail to validate the type of `fields.properties` on block creation which allows an authenticated user with editor access to a board to crash the Boards plugin worker and trigger a denial of service via a child block whose `fields.properties` is a non-object value. Mattermost Advisory ID: MMSA-2026-00710

## Affected

- `mattermost_server >= 10.11.0, < 10.11.23`
- `mattermost_server >= 11.7.0, < 11.7.8`
- `mattermost_server >= 11.8.0, < 11.8.5`
- `mattermost_server >= 11.9.0, < 11.9.1`

## Remediation

Upgrade past the affected range:

- `mattermost_server 11.9.1`
