---
id: CVE-2026-14991
title: >-
  IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6,
  10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 is vulnerable to a
  buffer overflow, caused by improper bounds checking
summary: >-
  IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6,
  10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 is vulnerable to a
  buffer overflow, caused by improper bounds checking. A local user could
  overflow the bu…
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-787
vendor: ibm
product: datapower_gateway
affected:
  - 'datapower_gateway >= 10.5.0.0, < 10.5.0.23'
  - 'datapower_gateway >= 10.6.0.0, < 10.6.0.11'
  - 'datapower_gateway >= 10.6.1.0, < 11.0.0.3'
  - 'datapower_gateway >= 11.0.0.0, < 11.0.0.3'
patched:
  - datapower_gateway 11.0.0.3
published: '2026-10-08'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T00:02:42.217'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-14991'
references:
  - url: 'https://www.ibm.com/support/pages/node/7289775'
    label: psirt@us.ibm.com
tags:
  - nvd
  - cve.org
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-09T03:55:45.738777Z'
epss: 0.00417
epssPercentile: 0.3586
ingestedAt: '2026-10-08T14:47:16.342Z'
---

## Overview

IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6, 10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 is vulnerable to a buffer overflow, caused by improper bounds checking. A local user could overflow the buffer and execute arbitrary code on the system.

## Affected

- `datapower_gateway >= 10.5.0.0, < 10.5.0.23`
- `datapower_gateway >= 10.6.0.0, < 10.6.0.11`
- `datapower_gateway >= 10.6.1.0, < 11.0.0.3`
- `datapower_gateway >= 11.0.0.0, < 11.0.0.3`

## Remediation

Upgrade past the affected range:

- `datapower_gateway 11.0.0.3`
