---
id: CVE-2026-14992
title: >-
  IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6,
  10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 vulnerable to buffer
  overflow.
summary: >-
  IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6,
  10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 vulnerable to buffer
  overflow.
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-787
vendor: ibm
product: datapower_gateway
affected:
  - 'datapower_gateway >= 10.5.0.0, < 10.5.0.23'
  - 'datapower_gateway >= 10.6.0.0, < 10.6.0.11'
  - 'datapower_gateway >= 10.6.1.0, < 11.0.0.3'
  - 'datapower_gateway >= 11.0.0.0, < 11.0.0.3'
patched:
  - datapower_gateway 11.0.0.3
published: '2026-10-08'
updated: '2026-10-14'
sourceUpdated: '2026-10-14T19:47:01.233'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-14992'
references:
  - url: 'https://www.ibm.com/support/pages/node/7289775'
    label: psirt@us.ibm.com
tags:
  - nvd
  - cve.org
epss: 0.00318
epssPercentile: 0.2459
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: total
  timestamp: '2026-10-08T14:32:50.686589Z'
ingestedAt: '2026-10-08T14:47:16.347Z'
---

## Overview

IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6, 10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 vulnerable to buffer overflow.

## Affected

- `datapower_gateway >= 10.5.0.0, < 10.5.0.23`
- `datapower_gateway >= 10.6.0.0, < 10.6.0.11`
- `datapower_gateway >= 10.6.1.0, < 11.0.0.3`
- `datapower_gateway >= 11.0.0.0, < 11.0.0.3`

## Remediation

Upgrade past the affected range:

- `datapower_gateway 11.0.0.3`
