---
id: CVE-2026-15222
title: >-
  The The User Registration & Membership – Free & Paid Memberships,
  Subscriptions, Content Restriction, User Profile, Custom User Registration &
  Login Builder plugin for WordPress is vulnerable to arbitrary shortcode
  execution in all versi…
summary: >-
  The The User Registration & Membership – Free & Paid Memberships,
  Subscriptions, Content Restriction, User Profile, Custom User Registration &
  Login Builder plugin for WordPress is vulnerable to arbitrary shortcode
  execution in all versi…
severity: medium
cvss: 5.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N'
cwe:
  - CWE-94
vendor: wpeverest
product: >-
  User Registration & Membership – Free & Paid Memberships, Subscriptions,
  Content Restriction, User Profile, Custom User Registration & Login Builder
affected:
  - >-
    user_registration_membership_free_paid_memberships_subscriptions_content_restriction_user_profile_custom_user_registration_login_builder
    <= 5.2.8
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T15:17:15.343'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-15222'
references:
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3741339/user-registration/trunk/includes/class-ur-smart-tags.php
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/f61873db-7365-41cb-a774-8f455a963d78?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00179
epssPercentile: 0.07409
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-16T14:53:54.183390Z'
ingestedAt: '2026-10-16T07:01:11.473Z'
---

## Overview

The The User Registration & Membership – Free & Paid Memberships, Subscriptions, Content Restriction, User Profile, Custom User Registration & Login Builder plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 5.2.8. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for authenticated attackers, with subscriber-level access and above, to execute arbitrary shortcodes.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
