---
id: CVE-2026-15272
title: >-
  Web 2.0 Directory <= 2.10.12 - Unauthenticated SQL Injection via
  'w2dc_level_filter' Parameter
summary: >-
  The Web 2.0 Directory plugin for WordPress is vulnerable to time-based SQL
  Injection via the 'w2dc_level_filter' parameter in all versions up to, and
  including, 2.10.12 due to insufficient escaping on the user supplied parameter
  and lack…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N'
cvssSource: cna
cwe:
  - CWE-89
vendor: Shamalli
product: Web 2.0 Directory plugin for WordPress
affected:
  - web_2.0_directory_plugin_for_wordpress <= 2.10.12
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-01T17:30:52.036922Z'
published: '2026-10-31'
updated: '2026-11-01'
sourceUpdated: '2026-11-01T17:37:50.660Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-15272'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/317e155b-5d7b-447b-93db-65b5f242a66d?source=cve
  - url: 'https://codecanyon.net/item/web-20-directory-plugin-for-wordpress/6463373'
tags:
  - cve.org
epss: 0.0032
epssPercentile: 0.25168
ingestedAt: '2026-11-05T19:30:42.591Z'
---

## Overview

The Web 2.0 Directory plugin for WordPress is vulnerable to time-based SQL Injection via the 'w2dc_level_filter' parameter in all versions up to, and including, 2.10.12 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. Because the parameter is used in integer context without surrounding quotes, WordPress's built-in addslashes/magic_quotes escaping provides no protection against time-based payloads such as SLEEP-based conditionals.

## Affected

- `web_2.0_directory_plugin_for_wordpress <= 2.10.12`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
