---
id: CVE-2026-15830
title: >-
  An issue was discovered in Django 6.0 before 6.0.9 and 5.2 before 5.2.18.

  GeoDjango's `django.contrib.gis.geos.GEOSGeometry` is subject to a potential
  denial-of-service when parsing deeply nested `GEOMETRYCOLLECTION` objects
  supplied as …
summary: >-
  An issue was discovered in Django 6.0 before 6.0.9 and 5.2 before 5.2.18.

  GeoDjango's `django.contrib.gis.geos.GEOSGeometry` is subject to a potential
  denial-of-service when parsing deeply nested `GEOMETRYCOLLECTION` objects
  supplied as …
severity: medium
cvss: 5.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L'
cwe:
  - CWE-674
vendor: djangoproject
product: django
affected:
  - django < 5.2.17
  - 'django >= 6.0, < 6.0.8'
patched:
  - django 6.0.8
published: '2026-08-04'
updated: '2026-10-08'
sourceUpdated: '2026-10-08T11:16:46.193'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-15830'
references:
  - url: 'https://docs.djangoproject.com/en/dev/releases/security/'
    label: 6a34fbeb-21d4-45e7-8e0a-62b95bc12c92
  - url: >-
      https://github.com/django/django/commit/1eafa1a80f1363283f89208ba4499ed54e35f085
    label: 6a34fbeb-21d4-45e7-8e0a-62b95bc12c92
  - url: >-
      https://github.com/django/django/commit/4353dfb56f8ba3a6fccc4bdd7f2ef2fbee3aa638
    label: 6a34fbeb-21d4-45e7-8e0a-62b95bc12c92
  - url: >-
      https://github.com/django/django/commit/62ef9d40cf4ea75f16518436b44b8ab2515340df
    label: 6a34fbeb-21d4-45e7-8e0a-62b95bc12c92
  - url: >-
      https://github.com/django/django/commit/6af5da31775417c610dbf9c3f1b5b8333d42daf6
    label: 6a34fbeb-21d4-45e7-8e0a-62b95bc12c92
  - url: >-
      https://github.com/django/django/commit/75d401a1491e04a907ed745c128836d51c982c0f
    label: 6a34fbeb-21d4-45e7-8e0a-62b95bc12c92
  - url: >-
      https://github.com/django/django/commit/9e4a3f186b6b07b483bfd9195ea06734663fcd06
    label: 6a34fbeb-21d4-45e7-8e0a-62b95bc12c92
  - url: >-
      https://github.com/django/django/commit/ba80833fa656dd09660b97c4429331067db1b080
    label: 6a34fbeb-21d4-45e7-8e0a-62b95bc12c92
  - url: >-
      https://github.com/django/django/commit/d2e59b77fe18de318a8272c2a7bbc798d84d1d0d
    label: 6a34fbeb-21d4-45e7-8e0a-62b95bc12c92
  - url: 'https://groups.google.com/g/django-announce'
    label: 6a34fbeb-21d4-45e7-8e0a-62b95bc12c92
  - url: 'https://www.djangoproject.com/weblog/2026/aug/04/security-releases/'
    label: 6a34fbeb-21d4-45e7-8e0a-62b95bc12c92
  - url: 'https://github.com/advisories/GHSA-q238-5cxm-5c9h'
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-15830'
  - url: 'https://docs.djangoproject.com/en/dev/releases/security'
  - url: 'https://github.com/django/django'
  - url: >-
      https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2026-3717.yaml
  - url: 'https://www.djangoproject.com/weblog/2026/aug/04/security-releases'
tags:
  - nvd
  - cve.org
  - osv
  - pip
  - ghsa
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-08-04T17:16:11.996083Z'
epss: 0.01113
epssPercentile: 0.65825
aliases:
  - PYSEC-2026-3717
  - BIT-django-2026-15830
  - GHSA-q238-5cxm-5c9h
ecosystem: pip
ingestedAt: '2026-08-19T19:22:21.743Z'
---

## Overview

An issue was discovered in Django 6.0 before 6.0.9 and 5.2 before 5.2.18.
GeoDjango's `django.contrib.gis.geos.GEOSGeometry` is subject to a potential denial-of-service when parsing deeply nested `GEOMETRYCOLLECTION` objects supplied as well-known text (WKT), well-known binary (WKB), or hex-encoded WKB, which triggers unbounded recursion and a segmentation fault in the underlying GEOS library. Spatial field lookups and the `django.contrib.gis.forms.GeometryField` form field are also affected.
Earlier, unsupported Django series (such as 5.1.x, 5.0.x, and 4.2.x) were not evaluated and may also be affected.
Django would like to thank Andrew MacPherson and kimchunbok_ for reporting this issue.

## Affected

- `django < 5.2.17`
- `django >= 6.0, < 6.0.8`

## Remediation

Upgrade past the affected range:

- `django 6.0.8`

## Package advisory (CVE-2026-15830)

Affected packages:

- `django >= 6.0, < 6.0.8`

Patched in:

- `django 6.0.8`

Source: https://osv.dev/vulnerability/PYSEC-2026-3717
