---
id: CVE-2026-16111
title: >-
  IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6,
  10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 could allow an
  attacker to cause a denial of service due to a type confusion flaw.
summary: >-
  IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6,
  10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 could allow an
  attacker to cause a denial of service due to a type confusion flaw.
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H'
cwe:
  - CWE-843
vendor: ibm
product: datapower_gateway
affected:
  - 'datapower_gateway >= 10.5.0.0, < 10.5.0.23'
  - 'datapower_gateway >= 10.6.0.0, < 10.6.0.11'
  - 'datapower_gateway >= 10.6.1.0, < 11.0.0.3'
  - 'datapower_gateway >= 11.0.0.0, < 11.0.0.3'
patched:
  - datapower_gateway 11.0.0.3
published: '2026-10-08'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T00:01:07.693'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-16111'
references:
  - url: 'https://www.ibm.com/support/pages/node/7289775'
    label: psirt@us.ibm.com
tags:
  - nvd
  - cve.org
epss: 0.00274
epssPercentile: 0.19722
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-08T15:50:12.760558Z'
ingestedAt: '2026-10-08T13:42:55.150Z'
---

## Overview

IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6, 10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 could allow an attacker to cause a denial of service due to a type confusion flaw.

## Affected

- `datapower_gateway >= 10.5.0.0, < 10.5.0.23`
- `datapower_gateway >= 10.6.0.0, < 10.6.0.11`
- `datapower_gateway >= 10.6.1.0, < 11.0.0.3`
- `datapower_gateway >= 11.0.0.0, < 11.0.0.3`

## Remediation

Upgrade past the affected range:

- `datapower_gateway 11.0.0.3`
