---
id: CVE-2026-16725
title: >-
  IBM Watson Speech Services Cartridge is vulnerable to a Path Traversal in
  LangSmith
summary: >-
  IBM Watson Speech Services Cartridge 4.0.0 through 5.4.0 could allow a remote
  authenticated attacker to read arbitrary files from the local filesystem due
  to path traversal.
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N'
cvssSource: cna
cwe:
  - CWE-22
vendor: IBM
product: Watson Speech Services Cartridge
affected:
  - watson_speech_services_cartridge >= 4.0.0 <= 5.4.0
published: '2026-11-04'
updated: '2026-11-04'
sourceUpdated: '2026-11-04T21:04:13.769Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-16725'
references:
  - url: 'https://www.ibm.com/support/pages/node/7293534'
tags:
  - cve.org
ingestedAt: '2026-11-05T21:36:00.589Z'
epss: 0.00366
epssPercentile: 0.30603
---

## Overview

IBM Watson Speech Services Cartridge 4.0.0 through 5.4.0 could allow a remote authenticated attacker to read arbitrary files from the local filesystem due to path traversal.

## Affected

- `watson_speech_services_cartridge >= 4.0.0 <= 5.4.0`

## Remediation

Product(s)Version(s)Remediation/Fix/InstructionsIBM Watson Speech Services Cartridge5.4.0 Patch 8 The fix in 5.4.0 Patch 8 applies to all versions listed (4.0.0-5.4.0). The newest version of 5.4.0 with the included Patch 8 can be downloaded and installed from:
 https://www.ibm.com/docs/en/cloud-paks/cp-data/5.4.x
