---
id: CVE-2026-16753
title: >-
  Incorrect authorization in the library-query execution endpoint in Lowcoder
  version, up to and including 2.4.10, allows an authenticated administrator or
  developer in one organization to execute a library query belonging to another
  organ…
summary: >-
  Incorrect authorization in the library-query execution endpoint in Lowcoder
  version, up to and including 2.4.10, allows an authenticated administrator or
  developer in one organization to execute a library query belonging to another
  organ…
severity: high
published: '2026-10-13'
updated: '2026-10-13'
sourceUpdated: '2026-10-13T21:17:37.847'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-16753'
references:
  - url: 'https://github.com/lowcoder-org/lowcoder'
    label: cret@cert.org
  - url: 'https://www.kb.cert.org/vuls/id/382143'
    label: af854a3a-2127-422b-91ae-364da2661108
tags:
  - nvd
  - cve.org
ingestedAt: '2026-10-13T20:53:44.637Z'
vendor: Lowcoder
product: Lowcoder
affected:
  - Lowcoder >= 2.1.0 <= 2.4.10
cwe:
  - CWE-863
  - CWE-639
epss: 0.00457
epssPercentile: 0.39478
cvss: 8.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-20T16:55:04.566551Z'
cvssSource: adp
---

## Overview

Incorrect authorization in the library-query execution endpoint in Lowcoder version, up to and including 2.4.10, allows an authenticated administrator or developer in one organization to execute a library query belonging to another organization via a crafted request containing the victim library-query identifier.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
