---
id: CVE-2026-16794
title: >-
  GitLab has remediated an issue in GitLab EE affecting all versions from 18.11
  before 19.1.8, 19.2 before 19.2.6, and 19.3 before 19.3.2 that under certain
  conditions could have allowed an authenticated user with the Security Manager
  role…
summary: >-
  GitLab has remediated an issue in GitLab EE affecting all versions from 18.11
  before 19.1.8, 19.2 before 19.2.6, and 19.3 before 19.3.2 that under certain
  conditions could have allowed an authenticated user with the Security Manager
  role…
severity: medium
cvss: 4.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N'
cwe:
  - CWE-862
vendor: gitlab
product: gitlab
affected:
  - 'gitlab >= 18.11.0, < 19.1.8'
  - 'gitlab >= 19.2.0, < 19.2.6'
  - 'gitlab >= 19.3.0, < 19.3.2'
patched:
  - gitlab 19.3.2
published: '2026-09-16'
updated: '2026-09-28'
sourceUpdated: '2026-09-28T15:21:11.253'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-16794'
references:
  - url: >-
      https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-3-2-released/
    label: cve@gitlab.com
  - url: 'https://gitlab.com/gitlab-org/gitlab/-/work_items/606750'
    label: cve@gitlab.com
  - url: 'https://hackerone.com/reports/3785754'
    label: cve@gitlab.com
tags:
  - nvd
  - cve.org
epss: 0.00392
epssPercentile: 0.33202
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-09-16T15:42:34.906182Z'
ingestedAt: '2026-09-16T06:51:06.262Z'
---

## Overview

GitLab has remediated an issue in GitLab EE affecting all versions from 18.11 before 19.1.8, 19.2 before 19.2.6, and 19.3 before 19.3.2 that under certain conditions could have allowed an authenticated user with the Security Manager role to execute arbitrary CI/CD jobs and access protected variables within group projects due to improper authorization controls on compliance framework management.

## Affected

- `gitlab >= 18.11.0, < 19.1.8`
- `gitlab >= 19.2.0, < 19.2.6`
- `gitlab >= 19.3.0, < 19.3.2`

## Remediation

Upgrade past the affected range:

- `gitlab 19.3.2`
