CVE-2026-17131Critical· 9.3▾ MidnightIBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote attacker to obtain sensitive information due to server-side request forgery. Restrictions on outbound requests can be bypassed, so the server could be made to contact uninten…
▾ Midnight zone — Critical, or high with PoC / in-the-wild
impact 51.2 · likelihood 0.1 · exploitation 0
Need a working PoC? Pro members can cast a request and our team develops one — it lands right here.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via CVEORG
0.4%
IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote attacker to obtain sensitive information due to server-side request forgery. Restrictions on outbound requests can be bypassed, so the server could be made to contact unintended destinations and return the response.
api_connect >= 12.1.0.0 <= 12.1.1.2IBM strongly recommends addressing the vulnerability now by upgrading to v12.1.1.3 Fix Central Link: https://www.ibm.com/support/pages/node/7290205
Connected by shared product, vendor, weakness, or advisory.
CVE-2026-16710Medium· 5.8Multiple Vulnerabilities in IBM API Connect
CVE-2026-16912High· 8.5Multiple Vulnerabilities in IBM API Connect
CVE-2026-16918Critical· 9.3Multiple Vulnerabilities in IBM API Connect
CVE-2026-17067Medium· 5.5Multiple Vulnerabilities in IBM API Connect
CVE-2026-17108High· 8.5Multiple Vulnerabilities in IBM API Connect
CVE-2026-17187High· 8.5Multiple Vulnerabilities in IBM API Connect