CVE-2026-17132Critical· 9.9▾ MidnightIBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to execute arbitrary SQL commands due to improper neutralization of special elements used in an SQL command.
▾ Midnight zone — Critical, or high with PoC / in-the-wild
impact 54.5 · likelihood 0.1 · exploitation 0
Need a working PoC? Pro members can cast a request and our team develops one — it lands right here.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via CVEORG
0.6%
IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to execute arbitrary SQL commands due to improper neutralization of special elements used in an SQL command.
api_connect >= 12.1.0.0 <= 12.1.1.2IBM strongly recommends addressing the vulnerability now by upgrading to v12.1.1.3 Fix Central Link: https://www.ibm.com/support/pages/node/7290205
Connected by shared product, vendor, weakness, or advisory.
CVE-2026-16854High· 7.7Multiple Vulnerabilities in IBM API Connect
CVE-2026-17134Critical· 9.9Multiple Vulnerabilities in IBM API Connect
CVE-2026-17336Critical· 9.9Multiple Vulnerabilities in IBM API Connect
CVE-2026-17345High· 7.7Multiple Vulnerabilities in IBM API Connect
CVE-2026-17363High· 7.7Multiple Vulnerabilities in IBM API Connect
CVE-2026-17396Critical· 9.6Multiple Vulnerabilities in IBM API Connect