---
id: CVE-2026-17140
title: Multiple Vulnerabilities in IBM API Connect
summary: >-
  IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could
  allow a remote authenticated attacker to execute arbitrary code due to
  improper control of generation of code. Input supplied by a user can influence
  code gen…
severity: low
cvss: 3.3
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-94
vendor: IBM
product: API Connect
affected:
  - api_connect >= 12.1.0.0 <= 12.1.1.2
  - api_connect >= 10.0.8.0 <= 10.0.8.12
published: '2026-11-07'
updated: '2026-11-07'
sourceUpdated: '2026-11-07T04:31:57.719Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-17140'
references:
  - url: 'https://www.ibm.com/support/pages/node/7295635'
  - url: 'https://www.ibm.com/support/pages/node/7295637'
tags:
  - cve.org
ingestedAt: '2026-11-07T05:10:28.980Z'
epss: 0.00374
epssPercentile: 0.31555
---

## Overview

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to execute arbitrary code due to improper control of generation of code. Input supplied by a user can influence code generated by the product, which could lead to code execution.

## Affected

- `api_connect >= 12.1.0.0 <= 12.1.1.2`
- `api_connect >= 10.0.8.0 <= 10.0.8.12`

## Remediation

IBM strongly recommends addressing the vulnerability now by upgrading to v12.1.1.3
Fix Central Link:  https://www.ibm.com/support/pages/node/7290205 



IBM strongly recommends addressing the vulnerability now by upgrading to 10.0.8.13Fix Central Link: https://www.ibm.com/support/fixcentral/swg/selectFixes?parent=ibm%7EWebSphere&product=ibm/WebSphere/IBM+API+Connect&release=10.0.8.12&platform=All&function=all
