CVE-2026-17150Critical· 9.9▾ MidnightIBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to execute arbitrary code and access sensitive information from other tenants due to insufficient input validation. Uplo…
▾ Midnight zone — Critical, or high with PoC / in-the-wild
impact 54.5 · likelihood 0.2 · exploitation 0
Need a working PoC? Pro members can cast a request and our team develops one — it lands right here.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via CVEORG
0.8%
IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to execute arbitrary code and access sensitive information from other tenants due to insufficient input validation. Uploaded custom module content is not sufficiently validated before it is processed, which could allow code to run with access beyond the user's own tenant.
api_connect >= 12.1.0.0 <= 12.1.1.2api_connect >= 10.0.8.0 <= 10.0.8.12IBM strongly recommends addressing the vulnerability now by upgrading to v12.1.1.3 Fix Central Link: https://www.ibm.com/support/pages/node/7290205
IBM strongly recommends addressing the vulnerability now by upgrading to 10.0.8.13Fix Central Link: https://www.ibm.com/support/fixcentral/swg/selectFixes?parent=ibm%7EWebSphere&product=ibm/WebSphere/IBM+API+Connect&release=10.0.8.12&platform=All&function=all
Connected by shared product, vendor, weakness, or advisory.
CVE-2026-105002High· 7.5Multiple Vulnerabilities in IBM API Connect
CVE-2026-105459Medium· 6.8Multiple Vulnerabilities in IBM API Connect
CVE-2026-108178Medium· 4.2Multiple Vulnerabilities in IBM API Connect
CVE-2026-16709High· 8.7Multiple Vulnerabilities in IBM API Connect
CVE-2026-16711Medium· 5.3Multiple Vulnerabilities in IBM API Connect
CVE-2026-16714High· 7.5Multiple Vulnerabilities in IBM API Connect