---
id: CVE-2026-17308
title: Multiple Vulnerabilities in IBM API Connect
summary: >-
  IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote attacker to
  obtain sensitive credentials and manipulate tool responses due to improper
  certificate validation.
severity: medium
cvss: 6.8
cvssVector: 'CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N'
cvssSource: cna
cwe:
  - CWE-295
vendor: IBM
product: API Connect
affected:
  - api_connect >= 12.1.0.0 <= 12.1.1.2
published: '2026-11-07'
updated: '2026-11-07'
sourceUpdated: '2026-11-07T04:33:00.073Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-17308'
references:
  - url: 'https://www.ibm.com/support/pages/node/7295635'
tags:
  - cve.org
ingestedAt: '2026-11-07T05:10:28.952Z'
epss: 0.00145
epssPercentile: 0.03767
---

## Overview

IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote attacker to obtain sensitive credentials and manipulate tool responses due to improper certificate validation.

## Affected

- `api_connect >= 12.1.0.0 <= 12.1.1.2`

## Remediation

IBM strongly recommends addressing the vulnerability now by upgrading to v12.1.1.3
Fix Central Link: https://www.ibm.com/support/pages/node/7290205
