---
id: CVE-2026-17319
title: Multiple Vulnerabilities in IBM API Connect
summary: >-
  IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated
  attacker to modify tool configuration and cause a denial of service due to
  improper authorization. Information supplied by the client is relied on when
  deciding…
severity: high
cvss: 7.1
cvssVector: 'CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:C/C:L/I:H/A:L'
cvssSource: cna
cwe:
  - CWE-862
vendor: IBM
product: API Connect
affected:
  - api_connect >= 12.1.0.0 <= 12.1.1.2
published: '2026-11-07'
updated: '2026-11-07'
sourceUpdated: '2026-11-07T04:33:11.644Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-17319'
references:
  - url: 'https://www.ibm.com/support/pages/node/7295635'
tags:
  - cve.org
ingestedAt: '2026-11-07T05:10:28.946Z'
---

## Overview

IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to modify tool configuration and cause a denial of service due to improper authorization. Information supplied by the client is relied on when deciding what a user is allowed to do, which could allow unauthorized changes that disrupt service.

## Affected

- `api_connect >= 12.1.0.0 <= 12.1.1.2`

## Remediation

IBM strongly recommends addressing the vulnerability now by upgrading to v12.1.1.3
Fix Central Link: https://www.ibm.com/support/pages/node/7290205
