---
id: CVE-2026-18535
title: IBM API Connect Denial of Service
summary: >-
  IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 are
  vulnerable to a Regular Expression Denial of Service (ReDoS) attack and to
  improper neutralisation of wildcard query operators.
severity: critical
cvss: 9.6
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:H'
cvssSource: cna
cwe:
  - CWE-1333
vendor: IBM
product: API Connect
affected:
  - api_connect >= 12.1.0.0 <= 12.1.1.2
  - api_connect >= 10.0.8.0 <= 10.0.8.12
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-08T01:45:54.241823Z'
published: '2026-11-07'
updated: '2026-11-08'
sourceUpdated: '2026-11-08T01:46:03.050Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-18535'
references:
  - url: 'https://www.ibm.com/support/pages/node/7291753'
  - url: 'https://www.ibm.com/support/pages/node/7292434'
tags:
  - cve.org
epss: 0.00287
epssPercentile: 0.21332
ingestedAt: '2026-11-07T05:10:28.782Z'
---

## Overview

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 are vulnerable to a Regular Expression Denial of Service (ReDoS) attack and to improper neutralisation of wildcard query operators.

## Affected

- `api_connect >= 12.1.0.0 <= 12.1.1.2`
- `api_connect >= 10.0.8.0 <= 10.0.8.12`

## Remediation

IBM strongly recommends addressing the vulnerability now by upgrading to v12.1.1.3
Fix Central Link:  https://www.ibm.com/support/pages/node/7290205 



IBM strongly recommends addressing the vulnerability now by upgrading to 10.0.8.13



Fix Central Link: https://www.ibm.com/support/fixcentral/swg/selectFixes?parent=ibm%7EWebSphere&product=ibm/WebSphere/IBM+API+Connect&release=10.0.8.12&platform=All&function=all
