---
id: CVE-2026-18807
title: >-
  The ECS  WordPress plugin before 4.3.13 does not have capability or ownership
  checks on its dynamic repeater actions, relying only on a nonce available to
  any user who can open the page builder, allowing users with a
  contributor-level ac…
summary: >-
  The ECS  WordPress plugin before 4.3.13 does not have capability or ownership
  checks on its dynamic repeater actions, relying only on a nonce available to
  any user who can open the page builder, allowing users with a
  contributor-level ac…
severity: medium
cvss: 4.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N'
cwe:
  - CWE-862
product: ECS
affected:
  - ECS < 4.3.13
published: '2026-08-15'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T12:16:39.067'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-18807'
references:
  - url: 'https://wpscan.com/vulnerability/bf500bf2-1684-4ca1-a8ad-bcff9cbc127c/'
    label: contact@wpscan.com
tags:
  - nvd
  - cve.org
  - exploit-available
epss: 0.00254
epssPercentile: 0.16882
exploitAvailable: true
ssvc:
  exploitation: poc
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-08-17T20:32:43.570967Z'
ingestedAt: '2026-08-16T04:33:12.625Z'
---

## Overview

The ECS  WordPress plugin before 4.3.13 does not have capability or ownership checks on its dynamic repeater actions, relying only on a nonce available to any user who can open the page builder, allowing users with a contributor-level account or above to read, alter and delete the binding configuration of posts they do not own and to change the ECS  WordPress plugin before 4.3.13's site-wide presets.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
