---
id: CVE-2026-22154
title: >-
  An improper neutralization of input during web page generation ('cross-site
  scripting') vulnerability in Fortinet FortiSOAR PaaS 7.6.0 through 7.6.3,
  FortiSOAR PaaS 7.5.0 through 7.5.2, FortiSOAR PaaS 7.4 all versions, FortiSOAR
  PaaS 7.3…
summary: >-
  An improper neutralization of input during web page generation ('cross-site
  scripting') vulnerability in Fortinet FortiSOAR PaaS 7.6.0 through 7.6.3,
  FortiSOAR PaaS 7.5.0 through 7.5.2, FortiSOAR PaaS 7.4 all versions, FortiSOAR
  PaaS 7.3…
severity: medium
cvss: 4.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N/E:H/RL:O/RC:C'
cvssSource: cna
cwe:
  - CWE-79
vendor: Fortinet
product: FortiSOAR on-premise
affected:
  - fortisoar_on-premise >= 7.6.0 <= 7.6.3
  - fortisoar_on-premise >= 7.5.0 <= 7.5.2
  - fortisoar_on-premise >= 7.4.0 <= 7.4.5
  - fortisoar_on-premise >= 7.3.0 <= 7.3.3
  - fortisoar_paas >= 7.6.0 <= 7.6.3
  - fortisoar_paas >= 7.5.0 <= 7.5.2
  - fortisoar_paas >= 7.4.0 <= 7.4.5
  - fortisoar_paas >= 7.3.0 <= 7.3.3
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-04-14T16:35:48.704992Z'
published: '2026-04-14'
updated: '2026-11-06'
sourceUpdated: '2026-11-06T15:42:05.727Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-22154'
references:
  - url: 'https://fortiguard.fortinet.com/psirt/FG-IR-26-117'
    label: 'https://fortiguard.fortinet.com/psirt/FG-IR-26-117'
tags:
  - cve.org
epss: 0.00221
epssPercentile: 0.12777
ingestedAt: '2026-11-06T15:54:03.988Z'
---

## Overview

An improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Fortinet FortiSOAR PaaS 7.6.0 through 7.6.3, FortiSOAR PaaS 7.5.0 through 7.5.2, FortiSOAR PaaS 7.4 all versions, FortiSOAR PaaS 7.3 all versions, FortiSOAR on-premise 7.6.0 through 7.6.3, FortiSOAR on-premise 7.5.0 through 7.5.2, FortiSOAR on-premise 7.4 all versions, FortiSOAR on-premise 7.3 all versions may allow an authenticated remote attacker to perform a stored cross site scripting (XSS) attack via crafted HTTP Requests.

## Affected

- `fortisoar_on-premise >= 7.6.0 <= 7.6.3`
- `fortisoar_on-premise >= 7.5.0 <= 7.5.2`
- `fortisoar_on-premise >= 7.4.0 <= 7.4.5`
- `fortisoar_on-premise >= 7.3.0 <= 7.3.3`
- `fortisoar_paas >= 7.6.0 <= 7.6.3`
- `fortisoar_paas >= 7.5.0 <= 7.5.2`
- `fortisoar_paas >= 7.4.0 <= 7.4.5`
- `fortisoar_paas >= 7.3.0 <= 7.3.3`

## Remediation

Upgrade to FortiSOAR on-premise version 7.6.4 or above
Upgrade to FortiSOAR on-premise version 7.5.3 or above
Upgrade to FortiSOAR PaaS version 7.6.4 or above
Upgrade to FortiSOAR PaaS version 7.5.3 or above
