---
id: CVE-2026-25689
title: >-
  An improper neutralization of argument delimiters in a command ('argument
  injection') vulnerability in Fortinet FortiDeceptor 6.2.0, FortiDeceptor 6.0
  all versions, FortiDeceptor 5.3 all versions, FortiDeceptor 5.2 all versions,
  FortiDec…
summary: >-
  An improper neutralization of argument delimiters in a command ('argument
  injection') vulnerability in Fortinet FortiDeceptor 6.2.0, FortiDeceptor 6.0
  all versions, FortiDeceptor 5.3 all versions, FortiDeceptor 5.2 all versions,
  FortiDec…
severity: medium
cvss: 6
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H/E:F/RL:O/RC:C'
cvssSource: cna
cwe:
  - CWE-88
vendor: Fortinet
product: FortiDeceptor
affected:
  - FortiDeceptor 6.2.0
  - FortiDeceptor >= 6.0.0 <= 6.0.4
  - FortiDeceptor >= 5.3.0 <= 5.3.4
  - FortiDeceptor >= 5.2.0 <= 5.2.2
  - FortiDeceptor 5.1.0
  - FortiDeceptor 5.0.0
  - FortiDeceptor 4.3.0
  - FortiDeceptor 4.2.0
  - FortiDeceptor >= 4.1.0 <= 4.1.1
  - FortiDeceptor >= 4.0.0 <= 4.0.2
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-03-10T17:32:37.881287Z'
published: '2026-03-10'
updated: '2026-11-06'
sourceUpdated: '2026-11-06T15:42:12.010Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-25689'
references:
  - url: 'https://fortiguard.fortinet.com/psirt/FG-IR-26-094'
    label: 'https://fortiguard.fortinet.com/psirt/FG-IR-26-094'
tags:
  - cve.org
epss: 0.00622
epssPercentile: 0.50067
ingestedAt: '2026-11-06T15:54:03.976Z'
---

## Overview

An improper neutralization of argument delimiters in a command ('argument injection') vulnerability in Fortinet FortiDeceptor 6.2.0, FortiDeceptor 6.0 all versions, FortiDeceptor 5.3 all versions, FortiDeceptor 5.2 all versions, FortiDeceptor 5.1 all versions, FortiDeceptor 5.0 all versions, FortiDeceptor 4.3 all versions, FortiDeceptor 4.2 all versions, FortiDeceptor 4.1 all versions, FortiDeceptor 4.0 all versions may allow a privileged attacker with super-admin profile and CLI access to delete sensitive files via crafted HTTP requests.

## Affected

- `FortiDeceptor 6.2.0`
- `FortiDeceptor >= 6.0.0 <= 6.0.4`
- `FortiDeceptor >= 5.3.0 <= 5.3.4`
- `FortiDeceptor >= 5.2.0 <= 5.2.2`
- `FortiDeceptor 5.1.0`
- `FortiDeceptor 5.0.0`
- `FortiDeceptor 4.3.0`
- `FortiDeceptor 4.2.0`
- `FortiDeceptor >= 4.1.0 <= 4.1.1`
- `FortiDeceptor >= 4.0.0 <= 4.0.2`

## Remediation

Upgrade to FortiDeceptor version 6.2.1 or above
Upgrade to FortiDeceptor version 6.1.0 or above
