---
id: CVE-2026-25917
title: >-
  Dag Authors, who normally should not be able to execute code in the webserver
  context could craft XCom payload causing the webserver to execute arbitrary
  code
summary: >-
  Dag Authors, who normally should not be able to execute code in the webserver
  context could craft XCom payload causing the webserver to execute arbitrary
  code. Since Dag Authors are already highly trusted, severity of this issue is
  Low.

  …
severity: high
cvss: 7.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-502
vendor: apache
product: airflow
affected:
  - airflow < 3.2.0
patched:
  - airflow 3.2.0
published: '2026-04-18'
updated: '2026-11-03'
sourceUpdated: '2026-11-03T07:18:38.563'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-25917'
references:
  - url: 'https://github.com/apache/airflow/pull/61641'
    label: security@apache.org
  - url: 'https://lists.apache.org/thread/6whgpkqbh12rvpfmvcg8b0vwlv4hq3po'
    label: security@apache.org
  - url: 'http://www.openwall.com/lists/oss-security/2026/04/17/9'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-25917'
  - url: 'https://github.com/apache/airflow'
  - url: >-
      https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2026-13.yaml
tags:
  - nvd
  - cve.org
  - osv
  - pip
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-04-22T03:55:40.721298Z'
epss: 0.00822
epssPercentile: 0.57426
aliases:
  - GHSA-6ffj-2wg2-w45j
  - BIT-airflow-2026-25917
  - PYSEC-2026-13
  - PYSEC-2026-2359
ecosystem: pip
ingestedAt: '2026-07-13T18:57:53.816Z'
---

## Overview

Dag Authors, who normally should not be able to execute code in the webserver context could craft XCom payload causing the webserver to execute arbitrary code. Since Dag Authors are already highly trusted, severity of this issue is Low.

Users are recommended to upgrade to Apache Airflow 3.2.0, which fixes the issue.

## Affected

- `airflow < 3.2.0`

## Remediation

Upgrade past the affected range:

- `airflow 3.2.0`

## Package advisory (CVE-2026-25917)

Affected packages:

- `apache-airflow-core < 3.2.0`

Patched in:

- `apache-airflow-core 3.2.0`

Source: https://osv.dev/vulnerability/GHSA-6ffj-2wg2-w45j
