---
id: CVE-2026-2611
title: >-
  In MLflow version 3.9.0, the MLflow Assistant feature introduced improper
  origin validation in its /ajax-api endpoints
summary: >-
  In MLflow version 3.9.0, the MLflow Assistant feature introduced improper
  origin validation in its /ajax-api endpoints. This vulnerability allows a
  remote attacker to exploit cross-origin requests from a malicious webpage to
  interact wit…
severity: critical
cvss: 9.6
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H'
cwe:
  - CWE-346
  - CWE-940
vendor: lfprojects
product: mlflow
affected:
  - 'mlflow >= 3.9.0, < 3.10.0'
patched:
  - mlflow 3.10.0
published: '2026-05-19'
updated: '2026-10-14'
sourceUpdated: '2026-10-14T20:10:00.190'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-2611'
references:
  - url: >-
      https://github.com/mlflow/mlflow/commit/8f9c8a53af90842944101eb8b7d60706822c81bc
    label: security@huntr.dev
  - url: 'https://huntr.com/bounties/8462addd-b464-4a84-b6a2-5529604e6e5a'
    label: security@huntr.dev
  - url: 'https://access.redhat.com/security/cve/CVE-2026-2611'
    label: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2479797'
    label: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
  - url: 'https://huntr.com/bounties/8462addd-b464-4a84-b6a2-5529604e6e5a'
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
  - url: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-2611.json
    label: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-2611'
  - url: 'https://github.com/advisories/GHSA-67c5-x5mf-rppq'
  - url: 'https://github.com/mlflow/mlflow'
  - url: >-
      https://github.com/pypa/advisory-database/tree/main/vulns/mlflow/PYSEC-2026-418.yaml
  - url: 'https://pypi.org/project/mlflow'
tags:
  - nvd
  - osv
  - pip
  - ghsa
epss: 0.00384
epssPercentile: 0.32607
aliases:
  - GHSA-67c5-x5mf-rppq
  - BIT-mlflow-2026-2611
  - PYSEC-2026-418
ecosystem: pip
ingestedAt: '2026-10-05T21:34:25.117Z'
---

## Overview

In MLflow version 3.9.0, the MLflow Assistant feature introduced improper origin validation in its /ajax-api endpoints. This vulnerability allows a remote attacker to exploit cross-origin requests from a malicious webpage to interact with the MLflow Assistant running on a victim's local machine. By bypassing the loopback-only restriction, the attacker can modify the Assistant's configuration to enable full access, which in turn allows the execution of arbitrary commands via the Claude Code sub-agent. This issue is resolved in version 3.10.0.

## Affected

- `mlflow >= 3.9.0, < 3.10.0`

## Remediation

Upgrade past the affected range:

- `mlflow 3.10.0`

## Package advisory (CVE-2026-2611)

Affected packages:

- `mlflow >= 3.9.0, < 3.10.0`

Patched in:

- `mlflow 3.10.0`

Source: https://osv.dev/vulnerability/GHSA-67c5-x5mf-rppq
