---
id: CVE-2026-26929
title: "Apache Airflow versions 3.0.0 through 3.1.7\_FastAPI DagVersion listing API does not apply per-DAG authorization filtering when the request is made with dag_id set to \"~\" (wildcard for all DAGs)"
summary: "Apache Airflow versions 3.0.0 through 3.1.7\_FastAPI DagVersion listing API does not apply per-DAG authorization filtering when the request is made with dag_id set to \"~\" (wildcard for all DAGs). As a result, version metadata of DAGs that…"
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N'
cwe:
  - CWE-732
vendor: apache
product: airflow
affected:
  - 'airflow >= 3.0.0, < 3.1.8'
patched:
  - airflow 3.1.8
published: '2026-03-17'
updated: '2026-11-03'
sourceUpdated: '2026-11-03T07:18:44.170'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-26929'
references:
  - url: 'https://github.com/apache/airflow/pull/61675'
    label: security@apache.org
  - url: 'https://lists.apache.org/thread/g5o6khx83jwqvdyn0mlyb0krt35cs9ss'
    label: security@apache.org
  - url: 'http://www.openwall.com/lists/oss-security/2026/03/17/4'
    label: af854a3a-2127-422b-91ae-364da2661108
tags:
  - nvd
  - cve.org
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-03-17T15:40:34.971798Z'
epss: 0.00422
epssPercentile: 0.367
ingestedAt: '2026-11-05T06:38:03.606Z'
---

## Overview

Apache Airflow versions 3.0.0 through 3.1.7 FastAPI DagVersion listing API does not apply per-DAG authorization filtering when the request is made with dag_id set to "~" (wildcard for all DAGs). As a result, version metadata of DAGs that the requester is not authorized to access is returned.


Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.

## Affected

- `airflow >= 3.0.0, < 3.1.8`

## Remediation

Upgrade past the affected range:

- `airflow 3.1.8`
