---
id: CVE-2026-27905
title: >-
  BentoML is a Python library for building online serving systems optimized for
  AI apps and model inference
summary: >-
  BentoML is a Python library for building online serving systems optimized for
  AI apps and model inference. Prior to 1.4.36, the safe_extract_tarfile()
  function validates that each tar member's path is within the destination
  directory, bu…
severity: high
cvss: 7.8
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H'
cwe:
  - CWE-59
vendor: bentoml
product: bentoml
affected:
  - bentoml < 1.4.36
patched:
  - bentoml 1.4.36
published: '2026-03-03'
updated: '2026-10-07'
sourceUpdated: '2026-10-07T08:10:00.200'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-27905'
references:
  - url: >-
      https://github.com/bentoml/BentoML/commit/4e0eb007765ac04c7924220d643f264715cc9670
    label: security-advisories@github.com
  - url: 'https://github.com/bentoml/BentoML/security/advisories/GHSA-m6w7-qv66-g3mf'
    label: security-advisories@github.com
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-27905'
  - url: 'https://github.com/bentoml/BentoML'
tags:
  - nvd
  - osv
  - pip
epss: 0.00267
epssPercentile: 0.18743
aliases:
  - GHSA-m6w7-qv66-g3mf
  - PYSEC-2026-2398
ecosystem: pip
ingestedAt: '2026-07-13T18:58:00.420Z'
---

## Overview

BentoML is a Python library for building online serving systems optimized for AI apps and model inference. Prior to 1.4.36, the safe_extract_tarfile() function validates that each tar member's path is within the destination directory, but for symlink members it only validates the symlink's own path, not the symlink's target. An attacker can create a malicious bento/model tar file containing a symlink pointing outside the extraction directory, followed by a regular file that writes through the symlink, achieving arbitrary file write on the host filesystem. This vulnerability is fixed in 1.4.36.

## Affected

- `bentoml < 1.4.36`

## Remediation

Upgrade past the affected range:

- `bentoml 1.4.36`

## Package advisory (CVE-2026-27905)

Affected packages:

- `bentoml < 1.4.36`

Patched in:

- `bentoml 1.4.36`

Source: https://osv.dev/vulnerability/GHSA-m6w7-qv66-g3mf
