---
id: CVE-2026-28335
title: SolarWinds Dameware Buffer Overflow Vulnerability
summary: >-
  SolarWinds Dameware was found to be affected by a buffer overflow
  vulnerability that can result in remote code execution. Authentication is
  required.
severity: high
cvss: 8.4
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:L'
cvssSource: cna
cwe:
  - CWE-20
vendor: SolarWinds
product: Dameware
affected:
  - Dameware <= 2026.3
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-11-03T00:00:00+00:00'
published: '2026-11-03'
updated: '2026-11-04'
sourceUpdated: '2026-11-04T04:56:28.757Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-28335'
references:
  - url: >-
      https://https://documentation.solarwinds.com/en/success_center/dameware/content/release_notes/dameware_2026-3-1_release_notes.htm
  - url: 'https://www.solarwinds.com/trust-center/security-advisories/CVE-2026-28335'
tags:
  - cve.org
epss: 0.01036
epssPercentile: 0.64115
ingestedAt: '2026-11-05T20:33:06.681Z'
---

## Overview

SolarWinds Dameware was found to be affected by a buffer overflow vulnerability that can result in remote code execution. Authentication is required.

## Affected

- `Dameware <= 2026.3`

## Remediation

SolarWinds recommends customers to upgrade to Dameware 2026.3.1 as soon as is practical.
