---
id: CVE-2026-29783
title: >-
  The shell tool within GitHub Copilot CLI versions prior to and including
  0.0.422 can allow arbitrary code execution through crafted bash parameter
  expansion patterns
summary: >-
  The shell tool within GitHub Copilot CLI versions prior to and including
  0.0.422 can allow arbitrary code execution through crafted bash parameter
  expansion patterns. An attacker who can influence the commands executed by the
  agent (e.g.…
severity: high
cvss: 7.8
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H'
cwe:
  - CWE-78
vendor: github
product: copilot_command_line_interface
affected:
  - copilot_command_line_interface < 0.0.423
patched:
  - copilot_command_line_interface 0.0.423
published: '2026-03-06'
updated: '2026-11-03'
sourceUpdated: '2026-11-03T23:17:41.810'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-29783'
references:
  - url: 'https://github.com/github/copilot-cli/releases/tag/v0.0.423'
    label: security-advisories@github.com
  - url: >-
      https://github.com/github/copilot-cli/security/advisories/GHSA-g8r9-g2v8-jv6f
    label: security-advisories@github.com
tags:
  - nvd
  - cve.org
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-03-11T03:56:38.865465Z'
scores:
  nvd: 7.8
  cna: 7.5
epss: 0.00468
epssPercentile: 0.40706
ingestedAt: '2026-11-05T06:38:03.605Z'
---

## Overview

The shell tool within GitHub Copilot CLI versions prior to and including 0.0.422 can allow arbitrary code execution through crafted bash parameter expansion patterns. An attacker who can influence the commands executed by the agent (e.g., via prompt injection through repository files, MCP server responses, or user instructions) can exploit bash parameter transformation operators to execute hidden commands, bypassing the safety assessment that classifies commands as "read-only." This has been patched in version 0.0.423. 

The vulnerability stems from how the CLI's shell safety assessment evaluates commands before execution. The safety layer parses and classifies shell commands as either read-only (safe) or write-capable (requires user approval). However, several bash parameter expansion features can embed executable code within arguments to otherwise read-only commands, causing them to appear safe while actually performing arbitrary operations.

The specific dangerous patterns are ${var@P}, ${var=value} / ${var:=value}, ${!var}, and nested $(cmd) or <(cmd) inside ${...} expansions. An attacker who can influence command text sent to the shell tool - for example, through prompt injection via malicious repository content (README files, code comments, issue bodies), compromised or malicious MCP server responses, or crafted user instructions containing obfuscated commands - could achieve arbitrary code execution on the user's workstation. This is possible even in permission modes that require user approval for write operations, since the commands can appear to use only read-only utilities to ultimately trigger write operations. Successful exploitation could lead to data exfiltration, file modification, or further system compromise.

## Affected

- `copilot_command_line_interface < 0.0.423`

## Remediation

Upgrade past the affected range:

- `copilot_command_line_interface 0.0.423`
