---
id: CVE-2026-30897
title: >-
  A stack-based buffer overflow vulnerability in Fortinet FortiWeb 8.0.0 through
  8.0.3, FortiWeb 7.6.0 through 7.6.6, FortiWeb 7.4.0 through 7.4.11, FortiWeb
  7.2 all versions, FortiWeb 7.0 all versions may allow a remote authenticated
  atta…
summary: >-
  A stack-based buffer overflow vulnerability in Fortinet FortiWeb 8.0.0 through
  8.0.3, FortiWeb 7.6.0 through 7.6.6, FortiWeb 7.4.0 through 7.4.11, FortiWeb
  7.2 all versions, FortiWeb 7.0 all versions may allow a remote authenticated
  atta…
severity: medium
cvss: 5.9
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H/E:P/RL:O/RC:C'
cvssSource: cna
cwe:
  - CWE-121
vendor: Fortinet
product: FortiWeb
affected:
  - FortiWeb >= 8.0.0 <= 8.0.3
  - FortiWeb >= 7.6.0 <= 7.6.6
  - FortiWeb >= 7.4.0 <= 7.4.11
  - FortiWeb >= 7.2.0 <= 7.2.13
  - FortiWeb >= 7.0.0 <= 7.0.12
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-03-10T00:00:00+00:00'
published: '2026-03-10'
updated: '2026-11-06'
sourceUpdated: '2026-11-06T15:42:14.778Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-30897'
references:
  - url: 'https://fortiguard.fortinet.com/psirt/FG-IR-26-093'
    label: 'https://fortiguard.fortinet.com/psirt/FG-IR-26-093'
tags:
  - cve.org
epss: 0.00734
epssPercentile: 0.54571
ingestedAt: '2026-11-06T15:54:03.972Z'
---

## Overview

A stack-based buffer overflow vulnerability in Fortinet FortiWeb 8.0.0 through 8.0.3, FortiWeb 7.6.0 through 7.6.6, FortiWeb 7.4.0 through 7.4.11, FortiWeb 7.2 all versions, FortiWeb 7.0 all versions may allow a remote authenticated attacker who can bypass stack protection and ASLR to execute arbitrary code or commands via crafted HTTP requests.

## Affected

- `FortiWeb >= 8.0.0 <= 8.0.3`
- `FortiWeb >= 7.6.0 <= 7.6.6`
- `FortiWeb >= 7.4.0 <= 7.4.11`
- `FortiWeb >= 7.2.0 <= 7.2.13`
- `FortiWeb >= 7.0.0 <= 7.0.12`

## Remediation

Upgrade to FortiWeb version 8.0.4 or above
Upgrade to FortiWeb version 7.6.7 or above
Upgrade to FortiWeb version 7.4.12 or above
