---
id: CVE-2026-32773
title: >-
  There is a lack of XSS escaping in the Spark History Server prior to 3.5.8
  which allows a malicious Spark job to generate arbitrary unescaped frontend
  code which could lead to a minimal privilege escalation in browser
summary: >-
  There is a lack of XSS escaping in the Spark History Server prior to 3.5.8
  which allows a malicious Spark job to generate arbitrary unescaped frontend
  code which could lead to a minimal privilege escalation in browser. Users are
  encourag…
severity: medium
cvss: 6.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N'
cwe:
  - CWE-80
  - CWE-79
vendor: apache
product: spark
affected:
  - 'spark >= 3.0.0, < 3.5.8'
patched:
  - spark 3.5.8
published: '2026-09-02'
updated: '2026-09-08'
sourceUpdated: '2026-09-08T13:04:14.690'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-32773'
references:
  - url: 'https://lists.apache.org/thread/k36prh3oxl1z6ov7w8rpmfnt07hmzw3v'
    label: security@apache.org
  - url: 'http://www.openwall.com/lists/oss-security/2026/09/01/4'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-32773'
  - url: 'https://github.com/apache/spark/pull/52851'
  - url: >-
      https://github.com/apache/spark/commit/3c83c2c6a22fe384280b99bb753b14800b7e27e1
  - url: >-
      https://github.com/apache/spark/commit/e739b7d349dbd41b78d49bc8086cab63db057e14
  - url: >-
      https://github.com/pypa/advisory-database/tree/main/vulns/pyspark/PYSEC-2026-3966.yaml
  - url: 'https://issues.apache.org/jira/browse/SPARK-53747'
  - url: 'https://github.com/advisories/GHSA-9437-39hj-3c93'
  - url: 'https://github.com/apache/spark'
  - url: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-32773.json
  - url: 'https://access.redhat.com/security/cve/CVE-2026-32773'
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2527318'
  - url: 'https://www.cve.org/CVERecord?id=CVE-2026-32773'
tags:
  - nvd
  - osv
  - pip
  - ghsa
  - csaf
  - vex
  - red-hat
  - score-dispute
epss: 0.00414
epssPercentile: 0.3556
ingestedAt: '2026-09-08T15:33:26.957Z'
aliases:
  - PYSEC-2026-3966
  - BIT-spark-2026-32773
  - GHSA-9437-39hj-3c93
ecosystem: pip
scores:
  nvd: 6.1
  vendor: 3.5
  osv: 6.1
---

## Overview

There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary unescaped frontend code which could lead to a minimal privilege escalation in browser. Users are encouraged to upgrade to Spark 3.5.8 or later.

This CVE is marked as "low" since the path to exploit requires both relatively high permissions (ability to launch a Spark job) and requires tricking a user with higher permissions to log in and visit the Spark history web page.

Users are encouraged to upgrade their Spark history servers to Spark 3.5.8 or later.

## Affected

- `spark >= 3.0.0, < 3.5.8`

## Remediation

Upgrade past the affected range:

- `spark 3.5.8`

## Package advisory (CVE-2026-32773)

Affected packages:

- `pyspark >= 3.0.0, < 3.5.8`

Patched in:

- `pyspark 3.5.8`

Source: https://osv.dev/vulnerability/PYSEC-2026-3966

## Vendor advisories

- **Red Hat VEX** · Low · affected: Red Hat Ceph Storage 7, Red Hat Ceph Storage 8, Red Hat Ceph Storage 9, Red Hat OpenShift AI (RHOAI) · no fix planned: Red Hat Ceph Storage 7, Red Hat Ceph Storage 8, Red Hat Ceph Storage 9, Red Hat OpenShift AI (RHOAI) · updated 2026-10-06 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-32773.json)
