---
id: CVE-2026-33858
title: >-
  Dag Authors, who normally should not be able to execute code in the webserver
  context could craft XCom payload causing the webserver to execute arbitrary
  code
summary: >-
  Dag Authors, who normally should not be able to execute code in the webserver
  context could craft XCom payload causing the webserver to execute arbitrary
  code. Since Dag Authors are already highly trusted, severity of this issue is
  Low.

  …
severity: high
cvss: 8.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-502
vendor: apache
product: airflow
affected:
  - 'airflow >= 3.1.8, < 3.2.0'
patched:
  - airflow 3.2.0
published: '2026-04-13'
updated: '2026-11-03'
sourceUpdated: '2026-11-03T07:19:41.870'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-33858'
references:
  - url: 'https://github.com/apache/airflow/pull/64148'
    label: security@apache.org
  - url: 'https://lists.apache.org/thread/1npt3o2x81s0gw9tmfcv4n7p1z9hdmy0'
    label: security@apache.org
  - url: 'http://www.openwall.com/lists/oss-security/2026/04/13/7'
    label: af854a3a-2127-422b-91ae-364da2661108
tags:
  - nvd
  - cve.org
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-04-13T00:00:00+00:00'
epss: 0.00592
epssPercentile: 0.48499
ingestedAt: '2026-11-05T06:38:03.610Z'
---

## Overview

Dag Authors, who normally should not be able to execute code in the webserver context could craft XCom payload causing the webserver to execute arbitrary code. Since Dag Authors are already highly trusted, severity of this issue is Low.


Users are recommended to upgrade to Apache Airflow 3.2.0, which resolves this issue.

## Affected

- `airflow >= 3.1.8, < 3.2.0`

## Remediation

Upgrade past the affected range:

- `airflow 3.2.0`
