---
id: CVE-2026-39918
title: Vvveb < 1.0.8.1 Code Injection via Installation Endpoint
summary: "Vvveb prior to\_1.0.8.1 contains a code injection vulnerability in the installation endpoint where the subdir POST parameter is written unsanitized into the env.php configuration file without escaping or validation. Attackers can inject a…"
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-94
vendor: givanz
product: Vvveb
affected:
  - Vvveb < 1.0.8.1
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: total
  timestamp: '2026-04-20T15:30:35.694606Z'
published: '2026-04-20'
updated: '2026-11-08'
sourceUpdated: '2026-11-08T14:02:33.942Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-39918'
references:
  - url: 'https://github.com/givanz/Vvveb/releases/tag/1.0.8.1'
    label: Vvveb 1.0.8.1 Release Notes
  - url: >-
      https://github.com/givanz/Vvveb/commit/5162c1639130bd080ab63c7d856788cd59d6b3b7
  - url: >-
      https://www.vulncheck.com/advisories/vvveb-code-injection-via-installation-endpoint
tags:
  - cve.org
epss: 0.00665
epssPercentile: 0.52047
ingestedAt: '2026-11-08T14:51:22.448Z'
---

## Overview

Vvveb prior to 1.0.8.1 contains a code injection vulnerability in the installation endpoint where the subdir POST parameter is written unsanitized into the env.php configuration file without escaping or validation. Attackers can inject arbitrary PHP code by breaking out of the string context in the define statement to achieve unauthenticated remote code execution as the web server user.

## Affected

- `Vvveb < 1.0.8.1`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
