---
id: CVE-2026-39922
title: >-
  GeoNode versions 4.4.5 and 5.0.2 (and prior within their respective releases)
  contain a server-side request forgery vulnerability in the service
  registration endpoint that allows authenticated attackers to trigger outbound
  network reques…
summary: >-
  GeoNode versions 4.4.5 and 5.0.2 (and prior within their respective releases)
  contain a server-side request forgery vulnerability in the service
  registration endpoint that allows authenticated attackers to trigger outbound
  network reques…
severity: medium
cvss: 6.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L'
cwe:
  - CWE-918
vendor: geosolutionsgroup
product: geonode
affected:
  - 'geonode >= 4.0.0, < 4.4.5'
  - 'geonode >= 5.0.0, < 5.0.2'
patched:
  - geonode 5.0.2
published: '2026-04-10'
updated: '2026-10-08'
sourceUpdated: '2026-10-08T16:17:14.380'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-39922'
references:
  - url: 'https://github.com/GeoNode/geonode/security/advisories/GHSA-hw9r-6m78-w6h3'
    label: disclosure@vulncheck.com
  - url: 'https://www.vulncheck.com/advisories/geonode-ssrf-via-service-registration'
    label: disclosure@vulncheck.com
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-39922'
  - url: 'https://github.com/GeoNode/geonode/releases/tag/4.4.5'
  - url: 'https://github.com/GeoNode/geonode/releases/tag/5.0.2'
  - url: >-
      https://github.com/pypa/advisory-database/tree/main/vulns/geonode/PYSEC-2026-61.yaml
  - url: 'https://github.com/advisories/GHSA-hw9r-6m78-w6h3'
tags:
  - nvd
  - cve.org
  - ghsa
  - pip
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-04-13T17:35:42.484560Z'
scores:
  nvd: 6.3
  cna: 5.3
  ghsa: 6.3
epss: 0.00172
epssPercentile: 0.06585
aliases:
  - GHSA-hw9r-6m78-w6h3
ecosystem: pip
ingestedAt: '2026-07-07T15:41:59.878Z'
---

## Overview

GeoNode versions 4.4.5 and 5.0.2 (and prior within their respective releases) contain a server-side request forgery vulnerability in the service registration endpoint that allows authenticated attackers to trigger outbound network requests to arbitrary URLs by submitting a crafted service URL during form validation. Attackers can probe internal network targets including loopback addresses, RFC1918 private IP ranges, link-local addresses, and cloud metadata services by exploiting insufficient URL validation in the WMS service handler without private IP filtering or allowlist enforcement.

## Affected

- `geonode >= 4.0.0, < 4.4.5`
- `geonode >= 5.0.0, < 5.0.2`

## Remediation

Upgrade past the affected range:

- `geonode 5.0.2`

## Package advisory (CVE-2026-39922)

Affected packages:

- `geonode >= 4.0.0, < 4.4.5`
- `geonode >= 5.0.0, < 5.0.2`

Patched in:

- `geonode 4.4.5`
- `geonode 5.0.2`

Source: https://github.com/advisories/GHSA-hw9r-6m78-w6h3
