---
id: CVE-2026-40035
title: >-
  Unfurl through 2025.08 contains an improper input validation vulnerability in
  config parsing that enables Flask debug mode by default
summary: >-
  Unfurl through 2025.08 contains an improper input validation vulnerability in
  config parsing that enables Flask debug mode by default. The debug
  configuration value is read as a string and passed directly to app.run(),
  causing any non-em…
severity: critical
cvss: 9.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N'
cwe:
  - CWE-489
vendor: ryandfir
product: unfurl
affected:
  - unfurl <= 2025.08
published: '2026-04-08'
updated: '2026-10-08'
sourceUpdated: '2026-10-08T16:17:14.723'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-40035'
references:
  - url: >-
      https://github.com/obsidianforensics/unfurl/security/advisories/GHSA-vg9h-jx4v-cwx2
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/dfir-unfurl-werkzeug-debugger-exposure-via-string-config-parsing
    label: disclosure@vulncheck.com
  - url: >-
      https://github.com/obsidianforensics/unfurl/security/advisories/GHSA-vg9h-jx4v-cwx2
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
  - url: >-
      https://github.com/obsidianforensics/unfurl/commit/4c0a07ab1e9af3a1ddf0e7f47153ec9ba77946dd
  - url: 'https://github.com/obsidianforensics/unfurl'
tags:
  - nvd
  - cve.org
  - exploit-available
  - osv
  - pip
exploitAvailable: true
ssvc:
  exploitation: poc
  automatable: 'yes'
  technicalImpact: total
  timestamp: '2026-04-09T13:19:52.114076Z'
epss: 0.00557
epssPercentile: 0.46229
aliases:
  - GHSA-vg9h-jx4v-cwx2
ecosystem: pip
ingestedAt: '2026-07-08T18:25:53.325Z'
---

## Overview

Unfurl through 2025.08 contains an improper input validation vulnerability in config parsing that enables Flask debug mode by default. The debug configuration value is read as a string and passed directly to app.run(), causing any non-empty string to evaluate truthy, allowing attackers to access the Werkzeug debugger and disclose sensitive information or achieve remote code execution.

## Affected

- `unfurl <= 2025.08`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-40035)

Affected packages:

- `dfir-unfurl <= 20250810`

Source: https://osv.dev/vulnerability/GHSA-vg9h-jx4v-cwx2
