---
id: CVE-2026-40176
title: Composer is vulnerable to Command Injection via Malicious Perforce Repository
summary: >-
  Composer is a dependency manager for PHP. Versions 1.0 through 2.2.26 and 2.3
  through 2.9.5 contain a command injection vulnerability in the
  Perforce::generateP4Command() method, which constructs shell commands by
  interpolating user-supp…
severity: high
cvss: 7.8
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-20
  - CWE-78
vendor: composer
product: composer
affected:
  - 'composer >= 2.3, < 2.9.6'
  - 'composer >= 1.0, < 2.2.27'
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-04-16T14:16:01.309579Z'
exploitAvailable: true
published: '2026-04-15'
updated: '2026-11-02'
sourceUpdated: '2026-11-02T23:04:32.552Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-40176'
references:
  - url: >-
      https://github.com/composer/composer/security/advisories/GHSA-wg36-wvj6-r67p
    label: >-
      https://github.com/composer/composer/security/advisories/GHSA-wg36-wvj6-r67p
  - url: 'https://access.redhat.com/errata/RHSA-2026:8165'
    label: 'https://access.redhat.com/errata/RHSA-2026:8165'
  - url: 'https://access.redhat.com/security/cve/CVE-2026-40176'
    label: 'https://access.redhat.com/security/cve/CVE-2026-40176'
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2458828'
    label: 'https://bugzilla.redhat.com/show_bug.cgi?id=2458828'
  - url: >-
      https://github.com/FriendsOfPHP/security-advisories/blob/master/composer/composer/CVE-2026-40176.yaml
    label: >-
      https://github.com/FriendsOfPHP/security-advisories/blob/master/composer/composer/CVE-2026-40176.yaml
  - url: 'https://github.com/composer/composer/releases/tag/2.2.27'
    label: 'https://github.com/composer/composer/releases/tag/2.2.27'
  - url: 'https://github.com/composer/composer/releases/tag/2.9.6'
    label: 'https://github.com/composer/composer/releases/tag/2.9.6'
  - url: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-40176.json
    label: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-40176.json
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-40176'
  - url: 'https://github.com/advisories/GHSA-wg36-wvj6-r67p'
tags:
  - cve.org
  - exploit-available
  - ghsa
  - composer
epss: 0.01045
epssPercentile: 0.64297
exploits:
  github: 3
  githubRepos:
    - 'https://github.com/Saku0512/CVE-2026-40176-poc'
    - 'https://github.com/daptheHuman/cve-2026-40176-cve-2026-40261'
    - 'https://github.com/ikarolaborda/CVE-2026-40176'
  checkedAt: '2026-11-06T17:09:35.354Z'
aliases:
  - GHSA-wg36-wvj6-r67p
ecosystem: composer
patched:
  - composer/composer 2.9.6
  - composer/composer 2.2.27
ingestedAt: '2026-11-02T23:32:19.618Z'
---

## Overview

Composer is a dependency manager for PHP. Versions 1.0 through 2.2.26 and 2.3 through 2.9.5 contain a command injection vulnerability in the Perforce::generateP4Command() method, which constructs shell commands by interpolating user-supplied Perforce connection parameters (port, user, client) without proper escaping. An attacker can inject arbitrary commands through these values in a malicious composer.json declaring a Perforce VCS repository, leading to command execution in the context of the user running Composer, even if Perforce is not installed. VCS repositories are only loaded from the root composer.json or the composer config directory, so this cannot be exploited through composer.json files of packages installed as dependencies. Users are at risk if they run Composer commands on untrusted projects with attacker-supplied composer.json files. This issue has been fixed in Composer 2.2.27 (2.2 LTS) and 2.9.6 (mainline).

## Affected

- `composer >= 2.3, < 2.9.6`
- `composer >= 1.0, < 2.2.27`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-40176)

Affected packages:

- `composer/composer >= 2.3.0, < 2.9.6`
- `composer/composer >= 1.0.0, < 2.2.27`

Patched in:

- `composer/composer 2.9.6`
- `composer/composer 2.2.27`

Source: https://github.com/advisories/GHSA-wg36-wvj6-r67p
