---
id: CVE-2026-41636
title: 'Apache Thrift: Node.js skip() recursion'
summary: |-
  Uncontrolled Recursion vulnerability in Apache Thrift Node.js bindings

  This issue affects Apache Thrift: before 0.23.0.

  Users are recommended to upgrade to version 0.23.0, which fixes the issue.
severity: high
cvss: 8.7
cvssVector: 'CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:L'
cvssSource: cna
cwe:
  - CWE-674
vendor: Apache Software Foundation
product: Apache Thrift
affected:
  - apache_thrift < 0.23.0
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-04-28T12:15:08.418018Z'
published: '2026-04-28'
updated: '2026-10-31'
sourceUpdated: '2026-10-31T20:36:23.426Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-41636'
references:
  - url: 'https://lists.apache.org/thread/lb4j0zyd5f3g36cos0wql925przpnwql'
tags:
  - cve.org
epss: 0.00451
epssPercentile: 0.393
ingestedAt: '2026-11-05T18:28:50.661Z'
---

## Overview

Uncontrolled Recursion vulnerability in Apache Thrift Node.js bindings

This issue affects Apache Thrift: before 0.23.0.

Users are recommended to upgrade to version 0.23.0, which fixes the issue.

## Affected

- `apache_thrift < 0.23.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
