---
id: CVE-2026-41934
title: Vvveb < 1.0.8.2 Authenticated RCE via Code Editor
summary: >-
  Vvveb before version 1.0.8.2 contains an authenticated remote code execution
  vulnerability in the admin code editor that allows low-privilege authenticated
  users to execute arbitrary code through insufficient file extension
  restrictions,…
severity: high
cvss: 8.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-184
vendor: givanz
product: Vvveb
affected:
  - Vvveb < 1.0.8.2
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-05-06T19:16:50.924960Z'
published: '2026-05-06'
updated: '2026-11-08'
sourceUpdated: '2026-11-08T14:03:12.024Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-41934'
references:
  - url: 'https://github.com/givanz/Vvveb/releases/tag/1.0.8.2'
    label: Vvveb 1.0.8.2 Release Notes
  - url: 'https://github.com/givanz/Vvveb/security/advisories/GHSA-vfjj-gcvv-w248'
    label: GitHub Security Advisory (GHSA-vfjj-gcvv-w248)
  - url: >-
      https://github.com/givanz/Vvveb/commit/1196561276a3f49da5a714fef89ac9a6c6f9e33b
  - url: >-
      https://www.vulncheck.com/advisories/vvveb-authenticated-rce-via-code-editor
tags:
  - cve.org
epss: 0.00545
epssPercentile: 0.45986
ingestedAt: '2026-11-08T14:51:22.435Z'
---

## Overview

Vvveb before version 1.0.8.2 contains an authenticated remote code execution vulnerability in the admin code editor that allows low-privilege authenticated users to execute arbitrary code through insufficient file extension restrictions, with the uploaded payload then executable via subsequent unauthenticated HTTP requests. Attackers with editor, author, contributor, or site_admin roles can write a malicious .htaccess file to map arbitrary extensions to the PHP handler, then upload PHP code with that extension to achieve unauthenticated remote code execution when the file is accessed via HTTP.

## Affected

- `Vvveb < 1.0.8.2`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
