CVE-2026-42266High· 8.8▾ TwilightJupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From 4.0.0 to 4.5.6, the allow-list of extensions that can be installed from PyPI Extension Manager (allowed_…
▾ Twilight zone — High severity, or a signal on a lesser flaw
impact 48.4 · likelihood 1.1 · exploitation 0
Need a working PoC? Pro members can cast a request and our team develops one — it lands right here.
Exploit-prediction probability, daily snapshots since Aug 2.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via NVD
Last analysed / modified upstream
0.6%
0.6% → 5.7%
JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From 4.0.0 to 4.5.6, the allow-list of extensions that can be installed from PyPI Extension Manager (allowed_extensions_uris) is not correctly enforced by JupyterLab. The PyPI Extension Manager was not contained to packages listed on the default PyPI index. This vulnerability is fixed in 4.5.7.
jupyterlab >= 4.0.0, < 4.5.7Upgrade past the affected range:
jupyterlab 4.5.7Affected packages:
jupyterlab >= 4.0.0, < 4.5.7Patched in:
jupyterlab 4.5.7Connected by shared product, vendor, weakness, or advisory.
CVE-2026-102904Medium· 5.4JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture
GHSA-h5v5-8746-g7mmMediumJupyterLab PluginManager lock-rule enforcement bypass
CVE-2026-102832Medium· 4.2JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture
CVE-2026-102830Medium· 6.8JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture
CVE-2026-102831High· 8.1JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture
CVE-2026-73626High· 7.5JupyterLab versions >=4.6.0,<=4.6.1 and <=4.5.9 contain an allowlist/blocklist enforcement gap in PyPIExtensionManager.install()