---
id: CVE-2026-42356
title: >-
  Deployment of wrong handler vulnerability in Apache HTTP Server allows the
  target of some internal redirects from CGI programs to also be treated as CGI
  and executed
summary: >-
  Deployment of wrong handler vulnerability in Apache HTTP Server allows the
  target of some internal redirects from CGI programs to also be treated as CGI
  and executed. The target must already be in a directory enabled for CGI and
  have no …
severity: low
cvss: 3.7
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N'
cwe:
  - CWE-430
vendor: apache
product: http_server
affected:
  - 'http_server >= 2.4.0, < 2.4.69'
patched:
  - http_server 2.4.69
published: '2026-10-01'
updated: '2026-10-06'
sourceUpdated: '2026-10-06T14:07:21.760'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-42356'
references:
  - url: 'https://httpd.apache.org/security/vulnerabilities_24.html'
    label: security@apache.org
  - url: 'http://www.openwall.com/lists/oss-security/2026/10/01/11'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42356.json
  - url: 'https://access.redhat.com/security/cve/CVE-2026-42356'
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2544825'
  - url: 'https://www.cve.org/CVERecord?id=CVE-2026-42356'
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-42356'
  - url: 'https://access.redhat.com/errata/RHSA-2026:74858'
tags:
  - nvd
  - cve.org
  - csaf
  - vex
  - red-hat
epss: 0.00422
epssPercentile: 0.36328
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-01T16:19:34.120406Z'
ingestedAt: '2026-10-01T18:55:42.356Z'
---

## Overview

Deployment of wrong handler vulnerability in Apache HTTP Server allows the target of some internal redirects from CGI programs to also be treated as CGI and executed. The target must already be in a directory enabled for CGI and have no other extension understood by mod_mime.



This issue affects Apache HTTP Server: from 2.4.60 through 2.4.68.

## Affected

- `http_server >= 2.4.0, < 2.4.69`

## Remediation

Upgrade past the affected range:

- `http_server 2.4.69`

## Vendor advisories

- **Red Hat VEX** · Low · affected: Red Hat Enterprise Linux 10, Red Hat Enterprise Linux 6, Red Hat Enterprise Linux 7, Red Hat Enterprise Linux 8, Red Hat Enterprise Linux 9, Red Hat Hardened Images · no fix planned: Red Hat Enterprise Linux 6, Red Hat Enterprise Linux 10, Red Hat Enterprise Linux 7, Red Hat Enterprise Linux 8, … · updated 2026-10-02 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42356.json)
- **RHSA-2026:74858** · Red Hat · fixed in: Red Hat Hardened Images · released 2026-10-02 · [advisory](https://access.redhat.com/errata/RHSA-2026:74858)
