---
id: CVE-2026-42694
title: WordPress Kirki plugin <= 6.4.0 - Content Injection vulnerability
summary: >-
  Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS)
  vulnerability in Themeum Kirki kirki allows Code Injection.This issue affects
  Kirki: from n/a through 6.4.0.
severity: medium
cvss: 4.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N'
cvssSource: cna
cwe:
  - CWE-80
vendor: Themeum
product: kirki
affected:
  - kirki <= 6.4.0
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-30T18:39:58.586742Z'
published: '2026-10-29'
updated: '2026-10-30'
sourceUpdated: '2026-10-30T18:50:05.330Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-42694'
references:
  - url: >-
      https://patchstack.com/database/wordpress/plugin/kirki/vulnerability/wordpress-kirki-plugin-6-4-0-content-injection-vulnerability?_s_id=cve
tags:
  - cve.org
epss: 0.00173
epssPercentile: 0.06832
ingestedAt: '2026-11-05T16:24:31.385Z'
---

## Overview

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Themeum Kirki kirki allows Code Injection.This issue affects Kirki: from n/a through 6.4.0.

## Affected

- `kirki <= 6.4.0`

## Remediation

Update the WordPress Kirki plugin to the latest available version (at least 6.4.1).
