---
id: CVE-2026-48068
title: >-
  grpc-js: @grpc/grpc-js: Server crash via malformed HTTP/2 stream initiation
  (CVE-2026-48068)
summary: >-
  A flaw was found in @grpc/grpc-js, a pure JavaScript gRPC client and server
  library. An invalid incoming HTTP/2 stream initiation can cause a server
  process to crash. This vulnerability affects all servers created using
  @grpc/grpc-js, and …
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H'
cvssSource: vendor
cwe: CWE-248
vendor: Red Hat
product: Red Hat Enterprise Linux AI (RHEL AI) 3
affected:
  - build_of_podman_desktop
  - developer_hub
  - enterprise_linux_ai_rhel_ai 3
  - openshift_dev_spaces
  - self_service_automation_portal 2
  - enterprise_linux_extensions_channel_v_10
  - ansible_automation_platform 2.1
  - ansible_automation_platform 2.2
  - developer_hub 1.10
  - developer_hub 1.9
  - openshift_dev_spaces 3.30
patched:
  - enterprise_linux_extensions_channel_v_10
  - ansible_automation_platform 2.1
  - ansible_automation_platform 2.2
  - developer_hub 1.10
  - developer_hub 1.9
  - openshift_dev_spaces 3.30
published: '2026-06-11'
updated: '2026-10-06'
sourceUpdated: '2026-10-06T19:29:44+00:00'
source: CSAF
sourceUrl: 'https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-48068.json'
references:
  - url: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-48068.json
  - url: 'https://access.redhat.com/security/cve/CVE-2026-48068'
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2499682'
  - url: 'https://www.cve.org/CVERecord?id=CVE-2026-48068'
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-48068'
  - url: 'https://github.com/grpc/grpc-node/security/advisories/GHSA-5375-pq7m-f5r2'
  - url: 'https://access.redhat.com/errata/RHSA-2026:57590'
  - url: 'https://access.redhat.com/errata/RHSA-2026:50850'
  - url: 'https://access.redhat.com/errata/RHSA-2026:50839'
  - url: 'https://access.redhat.com/errata/RHSA-2026:51162'
  - url: 'https://access.redhat.com/errata/RHSA-2026:48126'
  - url: 'https://access.redhat.com/errata/RHSA-2026:49642'
  - url: 'https://access.redhat.com/errata/RHSA-2026:52768'
  - url: 'https://access.redhat.com/errata/RHSA-2026:62260'
  - url: 'https://github.com/grpc/grpc-node/releases/tag/%40grpc%2Fgrpc-js%401.10.12'
  - url: 'https://github.com/grpc/grpc-node/releases/tag/%40grpc%2Fgrpc-js%401.11.4'
  - url: 'https://github.com/grpc/grpc-node/releases/tag/%40grpc%2Fgrpc-js%401.12.7'
  - url: 'https://github.com/grpc/grpc-node/releases/tag/%40grpc%2Fgrpc-js%401.13.5'
  - url: 'https://github.com/grpc/grpc-node/releases/tag/%40grpc%2Fgrpc-js%401.14.4'
  - url: 'https://github.com/grpc/grpc-node/releases/tag/%40grpc%2Fgrpc-js%401.9.16'
  - url: 'https://github.com/advisories/GHSA-5375-pq7m-f5r2'
tags:
  - csaf
  - vex
  - red-hat
  - ghsa
  - npm
epss: 0.00882
epssPercentile: 0.58955
aliases:
  - GHSA-5375-pq7m-f5r2
ecosystem: npm
ingestedAt: '2026-07-07T15:41:59.314Z'
---

## Overview

A flaw was found in @grpc/grpc-js, a pure JavaScript gRPC client and server library. An invalid incoming HTTP/2 stream initiation can cause a server process to crash. This vulnerability affects all servers created using @grpc/grpc-js, and no workaround is available. An unauthenticated remote attacker can exploit this to cause a denial of service by sending a malformed HTTP/2 stream to a gRPC server.

## Vendor advisories

- **RHSA-2026:57590** · Red Hat · fixed in: Red Hat Enterprise Linux Extensions Channel (v. 10) · released 2026-08-20 · [advisory](https://access.redhat.com/errata/RHSA-2026:57590)
- **RHSA-2026:50850** · Red Hat · fixed in: Red Hat Ansible Automation Platform 2.1 · released 2026-08-05 · [advisory](https://access.redhat.com/errata/RHSA-2026:50850)
- **RHSA-2026:50839** · Red Hat · fixed in: Red Hat Ansible Automation Platform 2.2 · released 2026-08-05 · [advisory](https://access.redhat.com/errata/RHSA-2026:50839)
- **RHSA-2026:51162** · Red Hat · fixed in: Red Hat Ansible Automation Platform 2.2 · released 2026-08-06 · [advisory](https://access.redhat.com/errata/RHSA-2026:51162)
- **RHSA-2026:48126** · Red Hat · fixed in: Red Hat Developer Hub 1.10 · released 2026-07-29 · [advisory](https://access.redhat.com/errata/RHSA-2026:48126)
- **RHSA-2026:49642** · Red Hat · fixed in: Red Hat Developer Hub 1.10 · released 2026-08-03 · [advisory](https://access.redhat.com/errata/RHSA-2026:49642)
- **RHSA-2026:52768** · Red Hat · fixed in: Red Hat Developer Hub 1.9 · released 2026-08-10 · [advisory](https://access.redhat.com/errata/RHSA-2026:52768)
- **RHSA-2026:62260** · Red Hat · fixed in: Red Hat OpenShift Dev Spaces 3.30 · released 2026-09-01 · [advisory](https://access.redhat.com/errata/RHSA-2026:62260)
- **Red Hat VEX** · Important · affected: Red Hat Build of Podman Desktop, Red Hat Developer Hub, Red Hat Enterprise Linux AI (RHEL AI) 3, Red Hat OpenShift Dev Spaces, Self-service automation portal 2 · no fix planned: Red Hat Enterprise Linux AI (RHEL AI) 3, Red Hat Build of Podman Desktop, Red Hat Developer Hub, Red Hat OpenShift Dev Spaces, … · updated 2026-10-06 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-48068.json)

**grpc-js: @grpc/grpc-js: Server crash via malformed HTTP/2 stream initiation** — rated Important by Red Hat. Released 2026-06-11, updated 2026-10-06.

Affected:

- Red Hat Build of Podman Desktop
- Red Hat Developer Hub
- Red Hat Enterprise Linux AI (RHEL AI) 3
- Red Hat OpenShift Dev Spaces
- Self-service automation portal 2

Fixed:

- Red Hat Enterprise Linux Extensions Channel (v. 10)
- Red Hat Ansible Automation Platform 2.1
- Red Hat Ansible Automation Platform 2.2
- Red Hat Developer Hub 1.10
- Red Hat Developer Hub 1.9
- Red Hat OpenShift Dev Spaces 3.30

No fix planned:

- Red Hat Enterprise Linux AI (RHEL AI) 3
- Red Hat Build of Podman Desktop
- Red Hat Developer Hub
- Red Hat OpenShift Dev Spaces
- Self-service automation portal 2

Not affected:

- Red Hat Developer Hub 1.10
- Red Hat Developer Hub 1.9
- Red Hat OpenShift Dev Spaces 3.30

## Remediation

For details on how to apply this update, which includes the changes described in this advisory, refer to:

https://access.redhat.com/articles/11258 https://access.redhat.com/errata/RHSA-2026:57590
For more about Ansible plugins for Red Hat Developer Hub, see References links https://access.redhat.com/errata/RHSA-2026:50850
For more about Ansible plugins for Red Hat Developer Hub, see References links https://access.redhat.com/errata/RHSA-2026:50839

Workarounds / mitigations:

- Upgrade to @grpc/grpc-js 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, or 1.14.4. There is no workaround for this vulnerability.

## Package advisory (CVE-2026-48068)

Affected packages:

- `@grpc/grpc-js < 1.9.16`
- `@grpc/grpc-js >= 1.10.0, < 1.10.12`
- `@grpc/grpc-js >= 1.11.0, < 1.11.4`
- `@grpc/grpc-js >= 1.12.0, < 1.12.7`
- `@grpc/grpc-js >= 1.13.0, < 1.13.5`
- `@grpc/grpc-js >= 1.14.0, < 1.14.4`

Patched in:

- `@grpc/grpc-js 1.9.16`
- `@grpc/grpc-js 1.10.12`
- `@grpc/grpc-js 1.11.4`
- `@grpc/grpc-js 1.12.7`
- `@grpc/grpc-js 1.13.5`
- `@grpc/grpc-js 1.14.4`

Source: https://github.com/advisories/GHSA-5375-pq7m-f5r2
