---
id: CVE-2026-49432
aliases:
  - GHSA-xjwq-9jw5-jf7w
title: >-
  Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp has an Improper
  Input Validation vulnerability
summary: >-
  Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp has an Improper
  Input Validation vulnerability
severity: high
cvss: 7.5
cwe:
  - CWE-20
  - CWE-839
vendor: apache
product: 'org.apache.activemq:apache-activemq'
ecosystem: maven
affected:
  - 'org.apache.activemq:apache-activemq < 5.19.8'
  - 'org.apache.activemq:apache-activemq >= 6.0.0, < 6.2.7'
  - 'org.apache.activemq:activemq-all < 5.19.8'
  - 'org.apache.activemq:activemq-all >= 6.0.0, < 6.2.7'
  - 'org.apache.activemq:activemq-stomp < 5.19.8'
  - 'org.apache.activemq:activemq-stomp >= 6.0.0, < 6.2.7'
patched:
  - 'org.apache.activemq:apache-activemq 5.19.8'
  - 'org.apache.activemq:apache-activemq 6.2.7'
  - 'org.apache.activemq:activemq-all 5.19.8'
  - 'org.apache.activemq:activemq-all 6.2.7'
  - 'org.apache.activemq:activemq-stomp 5.19.8'
  - 'org.apache.activemq:activemq-stomp 6.2.7'
published: '2026-06-30'
updated: '2026-11-05'
sourceUpdated: '2026-11-05T17:33:55Z'
source: GHSA
sourceUrl: 'https://github.com/advisories/GHSA-xjwq-9jw5-jf7w'
references:
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-49432'
  - url: 'https://lists.apache.org/thread/fsjb26605syqr8xks249h8gkp86t55d2'
  - url: 'http://www.openwall.com/lists/oss-security/2026/06/29/7'
  - url: 'https://github.com/apache/activemq/pull/2064'
  - url: >-
      https://github.com/apache/activemq/commit/1493db95b5918d4f4a305fd1df8155f57c38850b
  - url: >-
      https://github.com/apache/activemq/commit/63ca7332a47239964cbf2e343603412254ebb358
  - url: >-
      https://github.com/apache/activemq/commit/713cae920329c4caea016b08300182ec5c6dc99b
  - url: 'https://github.com/apache/activemq/releases/tag/activemq-5.19.8'
  - url: 'https://github.com/apache/activemq/releases/tag/activemq-6.2.7'
  - url: 'https://github.com/advisories/GHSA-xjwq-9jw5-jf7w'
tags:
  - ghsa
  - maven
epss: 0.00785
epssPercentile: 0.56202
ingestedAt: '2026-11-05T18:28:50.458Z'
---

## Overview

Improper Input Validation vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp.

A remote unauthenticated peer that can reach an exposed STOMP connector can trigger denial-of-service behavior by sending a negative content-length. For the NIO STOMP transport, an attacker can keep streaming body bytes and grow the per-connection command buffer beyond configured limits to cause OOM. For the blocking STOMP protocol, an error will instead force abnormal transport exception handling for the affected connection and closure.
This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Stomp: before 5.19.8, from 6.0.0 before 6.2.7.




Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.

## Affected packages

- `org.apache.activemq:apache-activemq < 5.19.8`
- `org.apache.activemq:apache-activemq >= 6.0.0, < 6.2.7`
- `org.apache.activemq:activemq-all < 5.19.8`
- `org.apache.activemq:activemq-all >= 6.0.0, < 6.2.7`
- `org.apache.activemq:activemq-stomp < 5.19.8`
- `org.apache.activemq:activemq-stomp >= 6.0.0, < 6.2.7`

## Remediation

Upgrade to a patched release:

- `org.apache.activemq:apache-activemq 5.19.8`
- `org.apache.activemq:apache-activemq 6.2.7`
- `org.apache.activemq:activemq-all 5.19.8`
- `org.apache.activemq:activemq-all 6.2.7`
- `org.apache.activemq:activemq-stomp 5.19.8`
- `org.apache.activemq:activemq-stomp 6.2.7`
