---
id: CVE-2026-49434
aliases:
  - GHSA-h5gm-rvw6-2xpx
title: >-
  Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All have an Improper
  Input Validation vulnerability
summary: >-
  Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All have an Improper
  Input Validation vulnerability
severity: high
cvss: 7.5
cwe:
  - CWE-20
vendor: apache
product: 'org.apache.activemq:activemq-broker'
ecosystem: maven
affected:
  - 'org.apache.activemq:activemq-broker < 5.19.8'
  - 'org.apache.activemq:activemq-broker >= 6.0.0, < 6.2.7'
  - 'org.apache.activemq:apache-activemq < 5.19.8'
  - 'org.apache.activemq:apache-activemq >= 6.0.0, < 6.2.7'
  - 'org.apache.activemq:activemq-all < 5.19.8'
  - 'org.apache.activemq:activemq-all >= 6.0.0, < 6.2.7'
patched:
  - 'org.apache.activemq:activemq-broker 5.19.8'
  - 'org.apache.activemq:activemq-broker 6.2.7'
  - 'org.apache.activemq:apache-activemq 5.19.8'
  - 'org.apache.activemq:apache-activemq 6.2.7'
  - 'org.apache.activemq:activemq-all 5.19.8'
  - 'org.apache.activemq:activemq-all 6.2.7'
published: '2026-06-30'
updated: '2026-11-04'
sourceUpdated: '2026-11-04T15:29:31Z'
source: GHSA
sourceUrl: 'https://github.com/advisories/GHSA-h5gm-rvw6-2xpx'
references:
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-49434'
  - url: 'https://lists.apache.org/thread/hcjh7kdk4l85tb9ksmvcnkhso1ngj50o'
  - url: 'http://www.openwall.com/lists/oss-security/2026/06/29/8'
  - url: 'https://github.com/apache/activemq/pull/2077'
  - url: >-
      https://github.com/apache/activemq/commit/0927bcb99e18c517728898be9f125589653ee899
  - url: >-
      https://github.com/apache/activemq/commit/ac3d06454bdf8b21db7ef419f42d17ab124a6008
  - url: >-
      https://github.com/apache/activemq/commit/f055bcc1dcd4a4a76b731fef43829fff515a7fbf
  - url: 'https://github.com/apache/activemq/releases/tag/activemq-5.19.8'
  - url: 'https://github.com/apache/activemq/releases/tag/activemq-6.2.7'
  - url: 'https://github.com/advisories/GHSA-h5gm-rvw6-2xpx'
tags:
  - ghsa
  - maven
epss: 0.0063
epssPercentile: 0.5033
ingestedAt: '2026-11-04T16:18:35.579Z'
---

## Overview

Improper Input Validation vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All.

An attacker that has access to publish or modify entries in LDAP that match the configured searchBase and searchFilter can instantiate denied transports inside the broker JVM. This can be used to fetch an attacker URL and spawn a second BrokerService inside the same JVM.
This issue affects Apache ActiveMQ Broker: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7.


Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.

## Affected packages

- `org.apache.activemq:activemq-broker < 5.19.8`
- `org.apache.activemq:activemq-broker >= 6.0.0, < 6.2.7`
- `org.apache.activemq:apache-activemq < 5.19.8`
- `org.apache.activemq:apache-activemq >= 6.0.0, < 6.2.7`
- `org.apache.activemq:activemq-all < 5.19.8`
- `org.apache.activemq:activemq-all >= 6.0.0, < 6.2.7`

## Remediation

Upgrade to a patched release:

- `org.apache.activemq:activemq-broker 5.19.8`
- `org.apache.activemq:activemq-broker 6.2.7`
- `org.apache.activemq:apache-activemq 5.19.8`
- `org.apache.activemq:apache-activemq 6.2.7`
- `org.apache.activemq:activemq-all 5.19.8`
- `org.apache.activemq:activemq-all 6.2.7`
