---
id: CVE-2026-49476
title: >-
  python-soupsieve: Soupsieve: Denial of Service via crafted CSS selector string
  (CVE-2026-49476)
summary: >-
  A flaw was found in soupsieve, a CSS selector library used with Beautiful Soup
  4. This vulnerability allows a remote attacker to cause a denial of service
  (DoS) by supplying a specially crafted CSS selector string. The parser
  allocates unb…
severity: medium
cvss: 5.9
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H'
cvssSource: vendor
cwe:
  - CWE-770
  - CWE-400
vendor: Red Hat
product: Red Hat OpenShift AI 3.4
affected:
  - exploit_intelligence
  - lightspeed_core
  - migration_toolkit_for_applications 8
  - openshift_lightspeed
  - ansible_automation_platform 2
  - openshift_ai_rhoai
  - openshift_container_platform 4
  - openshift_virtualization 4
  - openstack_platform 17.1
  - quay 3
  - satellite 6
  - hardened_images
  - openshift_ai 3.4
patched:
  - hardened_images
  - openshift_ai 3.4
published: '2026-07-14'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T11:03:37+00:00'
source: CSAF
sourceUrl: 'https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-49476.json'
references:
  - url: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-49476.json
  - url: 'https://access.redhat.com/security/cve/CVE-2026-49476'
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2500715'
  - url: 'https://www.cve.org/CVERecord?id=CVE-2026-49476'
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-49476'
  - url: >-
      https://github.com/facelessuser/soupsieve/commit/28108ab805818c832d9568142a99844fd95a0d39
  - url: 'https://github.com/facelessuser/soupsieve/releases/tag/2.8.4'
  - url: >-
      https://github.com/facelessuser/soupsieve/security/advisories/GHSA-2wc2-fm75-p42x
  - url: 'https://access.redhat.com/errata/RHSA-2026:34119'
  - url: 'https://access.redhat.com/errata/RHSA-2026:60520'
  - url: 'https://github.com/facelessuser/soupsieve'
  - url: 'https://github.com/advisories/GHSA-2wc2-fm75-p42x'
tags:
  - csaf
  - vex
  - red-hat
  - osv
  - pip
  - ghsa
epss: 0.00644
epssPercentile: 0.50658
aliases:
  - GHSA-2wc2-fm75-p42x
  - PYSEC-2026-3071
ecosystem: pip
scores:
  vendor: 5.9
  osv: 7.5
ingestedAt: '2026-07-09T13:51:05.196Z'
---

## Overview

A flaw was found in soupsieve, a CSS selector library used with Beautiful Soup 4. This vulnerability allows a remote attacker to cause a denial of service (DoS) by supplying a specially crafted CSS selector string. The parser allocates unbounded memory when compiling large, comma-separated selector lists, leading to excessive memory consumption and system instability.

## Vendor advisories

- **RHSA-2026:34119** · Red Hat · fixed in: Red Hat Hardened Images · released 2026-07-01 · [advisory](https://access.redhat.com/errata/RHSA-2026:34119)
- **RHSA-2026:60520** · Red Hat · fixed in: Red Hat OpenShift AI 3.4 · released 2026-08-27 · [advisory](https://access.redhat.com/errata/RHSA-2026:60520)
- **Red Hat VEX** · Important · affected: Exploit Intelligence, Lightspeed Core, Migration Toolkit for Applications 8, OpenShift Lightspeed, Red Hat Ansible Automation Platform 2, Red Hat OpenShift AI (RHOAI), … · no fix planned: Exploit Intelligence, Lightspeed Core, Migration Toolkit for Applications 8, OpenShift Lightspeed, … · updated 2026-10-15 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-49476.json)

**python-soupsieve: Soupsieve: Denial of Service via crafted CSS selector string** — rated Important by Red Hat. Released 2026-07-14, updated 2026-10-15.

Affected:

- Exploit Intelligence
- Lightspeed Core
- Migration Toolkit for Applications 8
- OpenShift Lightspeed
- Red Hat Ansible Automation Platform 2
- Red Hat OpenShift AI (RHOAI)
- Red Hat OpenShift Container Platform 4
- Red Hat OpenShift Virtualization 4
- Red Hat OpenStack Platform 17.1
- Red Hat Quay 3
- Red Hat Satellite 6

Fixed:

- Red Hat Hardened Images
- Red Hat OpenShift AI 3.4

No fix planned:

- Exploit Intelligence
- Lightspeed Core
- Migration Toolkit for Applications 8
- OpenShift Lightspeed
- Red Hat Ansible Automation Platform 2
- Red Hat OpenShift Container Platform 4
- Red Hat OpenShift Virtualization 4
- Red Hat OpenStack Platform 17.1
- Red Hat Quay 3
- Red Hat Satellite 6
- Red Hat OpenShift AI (RHOAI)

Not affected:

- Red Hat OpenShift AI 3.4
- Red Hat Hardened Images
- Red Hat OpenShift AI (RHOAI)

## Remediation

For details on how to apply this update, which includes the changes described in this advisory, refer to:
https://images.redhat.com/ https://access.redhat.com/errata/RHSA-2026:34119
For Red Hat OpenShift AI 3.4.4 see the following documentation, which will be updated shortly for this release, for important instructions on how to upgrade your cluster and fully apply this errata update:

https://docs.redhat.com/en/documentation/red_hat_openshift_ai/ https://access.redhat.com/errata/RHSA-2026:60520

Workarounds / mitigations:

- There is no mitigation for this flaw other than updating the soupsieve package when upstream patches are available. The impact is limited to availability (denial of service) — an attacker cannot access or modify data through this vulnerability. Applications that do not process untrusted CSS selector strings are at reduced risk.

## Package advisory (CVE-2026-49476)

Affected packages:

- `soupsieve < 2.8.4`

Patched in:

- `soupsieve 2.8.4`

Source: https://osv.dev/vulnerability/GHSA-2wc2-fm75-p42x
