---
id: CVE-2026-49959
title: Hermes WebUI < 0.51.311 RCE via Git Configuration Injection
summary: >-
  Hermes WebUI before version 0.51.311 contains a remote code execution
  vulnerability that allows authenticated attackers to execute arbitrary
  commands by placing malicious executable Git configuration in a workspace
  repository's .git/conf…
severity: high
cvss: 8.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-78
vendor: nesquena
product: hermes-webui
affected:
  - hermes-webui < 0.51.311
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-06-10T13:49:28.044885Z'
published: '2026-06-09'
updated: '2026-11-08'
sourceUpdated: '2026-11-08T14:05:00.139Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-49959'
references:
  - url: 'https://github.com/nesquena/hermes-webui/releases/tag/v0.51.311'
    label: hermes-webui 0.51.311 Release Notes
  - url: 'https://github.com/nesquena/hermes-webui/pull/3776'
  - url: >-
      https://github.com/nesquena/hermes-webui/commit/938ac9f55b53def1eefb48c4c42dabaf9c22e99c
  - url: >-
      https://www.vulncheck.com/advisories/hermes-webui-rce-via-git-configuration-injection
tags:
  - cve.org
epss: 0.00945
epssPercentile: 0.61312
ingestedAt: '2026-11-08T14:51:22.381Z'
---

## Overview

Hermes WebUI before version 0.51.311 contains a remote code execution vulnerability that allows authenticated attackers to execute arbitrary commands by placing malicious executable Git configuration in a workspace repository's .git/config file. Attackers can exploit Git subprocess invocations in api/workspace_git.py through vectors such as core.fsmonitor during git status, protocol.ext.allow with ext:: remotes during git fetch, credential.helper, core.askPass, core.gitProxy, or inherited environment variables including GIT_SSH_COMMAND to achieve arbitrary command execution on the host running the application.

## Affected

- `hermes-webui < 0.51.311`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
