---
id: CVE-2026-5059
aliases:
  - GHSA-fgmx-xfp3-w28p
  - PYSEC-2026-288
title: aws-mcp has a Command Injection Remote Code Execution Vulnerability
summary: aws-mcp has a Command Injection Remote Code Execution Vulnerability
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
vendor: aws-mcp
product: aws-mcp
ecosystem: pip
affected:
  - aws-mcp <= 1.7.0
published: '2026-04-11'
updated: '2026-10-27'
sourceUpdated: '2026-10-27T15:30:05.495099034Z'
source: OSV
sourceUrl: 'https://osv.dev/vulnerability/GHSA-fgmx-xfp3-w28p'
references:
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-5059'
  - url: 'https://github.com/alexei-led/aws-mcp-server'
  - url: >-
      https://github.com/pypa/advisory-database/tree/main/vulns/aws-mcp/PYSEC-2026-288.yaml
  - url: 'https://pypi.org/project/aws-mcp'
  - url: 'https://www.zerodayinitiative.com/advisories/ZDI-26-245'
  - url: 'https://github.com/advisories/GHSA-fgmx-xfp3-w28p'
tags:
  - osv
  - pip
  - exploit-available
  - ghsa
epss: 0.01908
epssPercentile: 0.79653
exploits:
  github: 1
  githubRepos:
    - 'https://github.com/pwn0x000/CVE-2026-5059-poc'
  checkedAt: '2026-10-27T16:20:47.577Z'
exploitAvailable: true
zeroDay: true
cwe:
  - CWE-78
ingestedAt: '2026-10-27T16:11:58.721Z'
---

## Overview

aws-mcp-server AWS CLI Command Injection Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of aws-mcp-server. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the handling of the allowed commands list. The issue results from the lack of proper validation of a user-supplied string before using it to execute a system call. An attacker can leverage this vulnerability to execute code in the context of the MCP server. Was ZDI-CAN-27969.

## Affected packages

- `aws-mcp <= 1.7.0`

## Remediation

Refer to the advisory for the patched release.
