---
id: CVE-2026-51886
title: 'langflow-ai langflow v1.9.3 is affected by: Code Injection'
summary: >-
  langflow-ai langflow v1.9.3 is affected by: Code Injection. The impact is:
  execute arbitrary code (remote). The component is:
  src/backend/base/langflow/api/v1/validate.py:validate-post_validate_code-a-real-authenticated-http-post-to-api-…
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-94
vendor: langflow
product: langflow
affected:
  - 'langflow >= 1.7.2, < 1.10.1'
patched:
  - langflow 1.10.1
published: '2026-10-01'
updated: '2026-10-06'
sourceUpdated: '2026-10-06T01:16:36.093'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-51886'
references:
  - url: 'https://gist.github.com/Ro1ME/c11b1e63e4e8fca6b25275144f25ec2a'
    label: cve@mitre.org
  - url: 'https://github.com/langflow-ai/langflow/issues/13336'
    label: cve@mitre.org
  - url: 'https://github.com/langflow-ai/langflow/issues/13336'
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
  - url: >-
      https://github.com/langflow-ai/langflow/security/advisories/GHSA-w584-2h2r-2hvf
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-51886'
  - url: 'https://github.com/langflow-ai/langflow/pull/13696'
  - url: >-
      https://github.com/langflow-ai/langflow/commit/e7c33dbaade20b5295c7fa26bf83cc1ff68fba02
  - url: 'https://github.com/langflow-ai/langflow/releases/tag/v1.10.1'
  - url: 'https://github.com/advisories/GHSA-w584-2h2r-2hvf'
  - url: 'https://github.com/langflow-ai/langflow'
  - url: 'https://pypi.org/project/langflow'
tags:
  - nvd
  - cve.org
  - exploit-available
  - ghsa
  - pip
  - osv
exploitAvailable: true
ssvc:
  exploitation: poc
  automatable: 'yes'
  technicalImpact: total
  timestamp: '2026-10-05T23:56:06.740367Z'
epss: 0.00602
epssPercentile: 0.48581
aliases:
  - GHSA-w584-2h2r-2hvf
  - PYSEC-2026-4236
ecosystem: pip
scores:
  nvd: 9.8
  ghsa: 8.8
  adp: 9.8
  osv: 8.8
ingestedAt: '2026-10-01T23:03:32.776Z'
---

## Overview

langflow-ai langflow v1.9.3 is affected by: Code Injection. The impact is: execute arbitrary code (remote). The component is: src/backend/base/langflow/api/v1/validate.py:validate-post_validate_code-a-real-authenticated-http-post-to-api-v1. The attack vector is: Attack surface: HTTP or browser-backed service path. A public-facing route accepts raw Python source and forwards it into a server-side compile/exec validation path without any visible entitlement guard. ¶¶ A weakness has been identified in langflow-ai langflow up to 1.9.3. langflow contains a code injection vulnerability in validate-post_validate_code-a-real-authenticated-http-post-to-api-v1 (src/backend/base/langflow/api/v1/validate.py:13). An authenticated attacker can execute arbitrary Python code on the server by submitting malicious code to the /api/v1/validate/code endpoint, which directly executes user-supplied code without sandboxing or security controls.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-51886)

Affected packages:

- `langflow >= 1.7.2, < 1.10.1`

Patched in:

- `langflow 1.10.1`

Source: https://github.com/advisories/GHSA-w584-2h2r-2hvf
